From 02cd6d278f4545841f0953ab41c71203e024fc5e Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Sun, 2 Sep 2007 16:39:27 +0000
Subject: [PATCH] use a default VERSION field for kmod packages

SVN-Revision: 8575
---
 include/kernel.mk                 | 1 +
 package/acx-mac80211/Makefile     | 1 -
 package/acx/Makefile              | 1 -
 package/aodv-uu/Makefile          | 1 -
 package/ar7-atm/Makefile          | 1 -
 package/bcm43xx-mac80211/Makefile | 1 -
 package/broadcom-diag/Makefile    | 1 -
 package/broadcom-mmc/Makefile     | 1 -
 package/broadcom-wl/Makefile      | 1 -
 package/fonera-mp3-drv/Makefile   | 1 -
 package/fuse/Makefile             | 1 -
 package/kernel/Makefile           | 2 --
 package/mac80211/Makefile         | 1 -
 package/madwifi/Makefile          | 1 -
 package/nozomi/Makefile           | 1 -
 package/openswan/Makefile         | 1 -
 package/qc-usb/Makefile           | 1 -
 package/rt2500/Makefile           | 1 -
 package/rt2570/Makefile           | 1 -
 package/rt2x00/Makefile           | 1 -
 package/rt61/Makefile             | 1 -
 package/shfs/Makefile             | 1 -
 package/spca5xx-le/Makefile       | 1 -
 package/spca5xx/Makefile          | 1 -
 package/strongswan/Makefile       | 1 -
 package/switch/Makefile           | 1 -
 package/uvcvideo/Makefile         | 1 -
 package/wlcompat/Makefile         | 1 -
 package/zd1211/Makefile           | 1 -
 29 files changed, 1 insertion(+), 29 deletions(-)

diff --git a/include/kernel.mk b/include/kernel.mk
index b3eec97bb5d..00d1b8c44c2 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -92,6 +92,7 @@ define KernelPackage
     CATEGORY:=Kernel modules
     DESCRIPTION:=$(DESCRIPTION)
     EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))
+    VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(BOARD)-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
     $(call KernelPackage/$(1))
     $(call KernelPackage/$(1)/$(KERNEL))
     $(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index 7ad0022f6c5..be62c2ac640 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -33,7 +33,6 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX111 Mac80211 driver
   DESCRIPTION:=Driver for acx111 cards (Mac80211 version)
   DEPENDS:=@LINUX_2_6 +kmod-mac80211
-  VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   KCONFIG:=CONFIG_MAC80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
diff --git a/package/acx/Makefile b/package/acx/Makefile
index 85837cf08c2..210a80cb48a 100644
--- a/package/acx/Makefile
+++ b/package/acx/Makefile
@@ -30,7 +30,6 @@ define KernelPackage/acx
   DESCRIPTION:=\
 	This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
   URL:=http://acx100.sourceforge.net/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   SUBMENU:=Wireless Drivers
   FILES:= \
 		$(PKG_BUILD_DIR)/acx.$(LINUX_KMOD_SUFFIX)
diff --git a/package/aodv-uu/Makefile b/package/aodv-uu/Makefile
index 64cdb07e112..b670e1cca2b 100644
--- a/package/aodv-uu/Makefile
+++ b/package/aodv-uu/Makefile
@@ -46,7 +46,6 @@ define KernelPackage/aodv-uu
   FILES:=$(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Network Support
   AUTOLOAD:=$(call AutoLoad,80,$(shell cat ./files/aodv-uu.modules))
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 
 ifeq ($(CONFIG_LINUX_2_6),y)
diff --git a/package/ar7-atm/Makefile b/package/ar7-atm/Makefile
index c42895d59c6..756657db3fd 100644
--- a/package/ar7-atm/Makefile
+++ b/package/ar7-atm/Makefile
@@ -24,7 +24,6 @@ define KernelPackage/sangam-atm-annex-a
   DEPENDS:=@LINUX_2_6_AR7 +kmod-atm 
   TITLE:=AR7 ADSL driver (Annex A, ADSL over POTS)
   DESCRIPTION:=The AR7 ADSL driver for Annex A (ADSL over POTS)
-  VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/tiatm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,tiatm)
 endef
diff --git a/package/bcm43xx-mac80211/Makefile b/package/bcm43xx-mac80211/Makefile
index 8566bf4e409..c0d8a625875 100644
--- a/package/bcm43xx-mac80211/Makefile
+++ b/package/bcm43xx-mac80211/Makefile
@@ -23,7 +23,6 @@ define KernelPackage/bcm43xx-mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=Broadcom 43xx wireless support
   DESCRIPTION:=Kernel module for Broadcom 43xx wireless support (mac80211)
-  VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
   DEPENDS:=@LINUX_2_6_BRCM47XX +kmod-mac80211
   KCONFIG:=CONFIG_MAC80211
   FILES:=$(PKG_BUILD_DIR)/bcm43xx-mac80211.$(LINUX_KMOD_SUFFIX)
diff --git a/package/broadcom-diag/Makefile b/package/broadcom-diag/Makefile
index b21f33a63d8..266c30f767b 100644
--- a/package/broadcom-diag/Makefile
+++ b/package/broadcom-diag/Makefile
@@ -20,7 +20,6 @@ define KernelPackage/diag
   SUBMENU:=Other modules
   DEPENDS:=@LINUX_2_4_BRCM||LINUX_2_6_BRCM||LINUX_2_6_BRCM47XX
   TITLE:=Driver for router LEDs and Buttons
-  VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/diag.$(LINUX_KMOD_SUFFIX)
 endef
 
diff --git a/package/broadcom-mmc/Makefile b/package/broadcom-mmc/Makefile
index f3d30bc1c53..39b6d5390a1 100644
--- a/package/broadcom-mmc/Makefile
+++ b/package/broadcom-mmc/Makefile
@@ -31,7 +31,6 @@ define KernelPackage/broadcom-mmc
 	Kernel driver for the Linksys WRT54G MM/SD-Card Mod
   URL:=http://kiel.kool.dk/
   FILES:=$(PKG_BUILD_DIR)/mmc.$(LINUX_KMOD_SUFFIX)
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,80,mmc)
 endef 
 
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index 579033a77b7..da32a89312f 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -36,7 +36,6 @@ define KernelPackage/brcm-wl/Default
   DESCRIPTION:=\
 	This package contains the proprietary wireless driver for the Broadcom \\\
 	BCM43xx chipset
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/kmod/wl$(1).o
   AUTOLOAD:=$(call AutoLoad,30,wl$(1))
 endef
diff --git a/package/fonera-mp3-drv/Makefile b/package/fonera-mp3-drv/Makefile
index 81fbaddb9aa..d163b4acc1b 100644
--- a/package/fonera-mp3-drv/Makefile
+++ b/package/fonera-mp3-drv/Makefile
@@ -18,7 +18,6 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/fonera-mp3-driver
   SUBMENU:=Other modules
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(LINUX_RELEASE)
   DEPENDS:=@LINUX_2_6_ATHEROS
   TITLE:=Fonera-MP3 driver (VS1011X)
   DESCRIPTION:=driver for a vs1011X attached to a fonera
diff --git a/package/fuse/Makefile b/package/fuse/Makefile
index afdaa774c81..220e94ba078 100644
--- a/package/fuse/Makefile
+++ b/package/fuse/Makefile
@@ -47,7 +47,6 @@ define KernelPackage/fuse
 	\\\
 	This package contains the FUSE kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,80,fuse)
 endef
 
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index 3ec07d43ac5..0bc7c0ac5b0 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -10,8 +10,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
-PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
-PKG_RELEASE:=$(LINUX_RELEASE)
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
 SCAN_DEPS=modules/*.mk
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 6d72986ef0e..09e4114426e 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -26,7 +26,6 @@ define KernelPackage/mac80211
   KCONFIG:=CONFIG_MAC80211
   DESCRIPTION:=\
 	This package contains the DeviceScape 80211 wireless stack.
-  VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
   FILES:= \
 	$(PKG_BUILD_DIR)/mac80211/mac80211.$(LINUX_KMOD_SUFFIX) \
 	$(PKG_BUILD_DIR)/mac80211/rc80211_lowest.$(LINUX_KMOD_SUFFIX) \
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index d2dc66a0db8..70177d96059 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -85,7 +85,6 @@ define KernelPackage/madwifi
   DESCRIPTION:=\
 	This package contains a driver for Atheros 802.11a/b/g chipsets.
   URL:=http://madwifi.org/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
 		$(PKG_BUILD_DIR)/ath_hal/ath_hal.$(LINUX_KMOD_SUFFIX) \
 		$(BUS_MODULES) \
diff --git a/package/nozomi/Makefile b/package/nozomi/Makefile
index 60ae74b77c5..c5b56b701bd 100644
--- a/package/nozomi/Makefile
+++ b/package/nozomi/Makefile
@@ -27,7 +27,6 @@ define KernelPackage/nozomi
   DESCRIPTION:=Option Globetrotter HSDPA driver
   URL:=http://www.pharscape.org/
   DEPENDS:=@LINUX_2_4 @PCMCIA_SUPPORT
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/noz.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,noz)
 endef
diff --git a/package/openswan/Makefile b/package/openswan/Makefile
index 9035a3c9848..e6502c4aad1 100644
--- a/package/openswan/Makefile
+++ b/package/openswan/Makefile
@@ -46,7 +46,6 @@ define KernelPackage/openswan
   DESCRIPTION+=\\\
 	\\\
 	This package contains the Openswan kernel module.
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/modobj*/ipsec.$(LINUX_KMOD_SUFFIX)
 endef
 
diff --git a/package/qc-usb/Makefile b/package/qc-usb/Makefile
index 78e6dc1da6a..d3cd4f7f98c 100644
--- a/package/qc-usb/Makefile
+++ b/package/qc-usb/Makefile
@@ -40,7 +40,6 @@ define KernelPackage/usb-qc
 	other webcams with similar chipsets.
   SUBMENU:=USB Support
   DEPENDS:=@LINUX_2_6 @USB_SUPPORT @VIDEO_SUPPORT kmod-usb-core +kmod-videodev
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/quickcam.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,quickcam)
 endef
diff --git a/package/rt2500/Makefile b/package/rt2500/Makefile
index 06e02f7ea1c..cd38c251672 100644
--- a/package/rt2500/Makefile
+++ b/package/rt2500/Makefile
@@ -26,7 +26,6 @@ define KernelPackage/rt2500
   DESCRIPTION:=\
 	This package contains a driver for ralink rt2500 pci chipsets.
   URL:=http://rt2x00.serialmonkey.com/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
 		$(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,rt2500)
diff --git a/package/rt2570/Makefile b/package/rt2570/Makefile
index 24c2470142d..629a443c239 100644
--- a/package/rt2570/Makefile
+++ b/package/rt2570/Makefile
@@ -26,7 +26,6 @@ define KernelPackage/rt2570
   DESCRIPTION:=\
 	This package contains a driver for ralink rt2570 usb chipsets.
   URL:=http://rt2x00.serialmonkey.com/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
 		$(PKG_BUILD_DIR)/Module/rt2570.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,rt2570)
diff --git a/package/rt2x00/Makefile b/package/rt2x00/Makefile
index 0338b9333b0..85233b325ed 100644
--- a/package/rt2x00/Makefile
+++ b/package/rt2x00/Makefile
@@ -31,7 +31,6 @@ define KernelPackage/rt2x00/Default
   DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_MAC80211
   DESCRIPTION:=Ralink GPL Drivers for rt2x00 cards
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(LINUX_RELEASE)
 endef
 
 define KernelPackage/rt2x00-lib
diff --git a/package/rt61/Makefile b/package/rt61/Makefile
index 3b0564f286c..db8ceb717b9 100644
--- a/package/rt61/Makefile
+++ b/package/rt61/Makefile
@@ -26,7 +26,6 @@ define KernelPackage/rt61
   DESCRIPTION:=\
         This package contains a driver for ralink rt2x61 pci chipsets.
   URL:=http://rt2x00.serialmonkey.com/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
                 $(PKG_BUILD_DIR)/Module/rt61.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,rt61)
diff --git a/package/shfs/Makefile b/package/shfs/Makefile
index 24bf094df86..086a538319b 100644
--- a/package/shfs/Makefile
+++ b/package/shfs/Makefile
@@ -37,7 +37,6 @@ define KernelPackage/shfs
 	This package contains the ShFS kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Filesystems
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef
 
diff --git a/package/spca5xx-le/Makefile b/package/spca5xx-le/Makefile
index 82faba6b303..0ed29c0b052 100644
--- a/package/spca5xx-le/Makefile
+++ b/package/spca5xx-le/Makefile
@@ -25,7 +25,6 @@ define KernelPackage/spca5xx-le
   DEPENDS:=@LINUX_2_6 kmod-videodev @VIDEO_SUPPORT
   TITLE:=Driver for SPCA5xx based USB cameras (Light Edition)
   URL:=http://mxhaard.free.fr/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,spca5xx)
 endef
diff --git a/package/spca5xx/Makefile b/package/spca5xx/Makefile
index f0b28b72a9c..c0f6ea5f70a 100644
--- a/package/spca5xx/Makefile
+++ b/package/spca5xx/Makefile
@@ -24,7 +24,6 @@ define KernelPackage/gspca
   DEPENDS:=@LINUX_2_6 kmod-usb-core kmod-videodev @VIDEO_SUPPORT
   TITLE:=Driver for SPCA5xx based USB cameras
   URL:=http://mxhaard.free.fr/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/gspca.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,gspca)
 endef
diff --git a/package/strongswan/Makefile b/package/strongswan/Makefile
index 9993b3b034b..286b0bb60ab 100644
--- a/package/strongswan/Makefile
+++ b/package/strongswan/Makefile
@@ -47,7 +47,6 @@ define KernelPackage/strongswan
   DESCRIPTION+=\\\
 	\\\
 	This package contains the strongSwan kernel module.
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/linux/net/ipsec/ipsec.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,ipsec)
 endef
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 81ae3465553..57616685fb3 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -22,7 +22,6 @@ define KernelPackage/switch
   TITLE:=Switch drivers
   DESCRIPTION:=\
 	This package contains switch drivers for ADM6996L and BCM53XX RoboSwitch.
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:= \
 	$(PKG_BUILD_DIR)/switch-core.$(LINUX_KMOD_SUFFIX) \
 	$(PKG_BUILD_DIR)/switch-adm.$(LINUX_KMOD_SUFFIX) \
diff --git a/package/uvcvideo/Makefile b/package/uvcvideo/Makefile
index c9c9f5ed308..847f73b2074 100644
--- a/package/uvcvideo/Makefile
+++ b/package/uvcvideo/Makefile
@@ -24,7 +24,6 @@ define KernelPackage/uvcvideo
   DEPENDS:=@LINUX_2_6 kmod-usb-core kmod-videodev @VIDEO_SUPPORT
   TITLE:=Driver for Linux-UVC based USB cameras
   URL:=http://linux-uvc.berlios.de/
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
 endef
diff --git a/package/wlcompat/Makefile b/package/wlcompat/Makefile
index 78f301a3827..bc52c0fcf9c 100644
--- a/package/wlcompat/Makefile
+++ b/package/wlcompat/Makefile
@@ -24,7 +24,6 @@ define KernelPackage/wlcompat/Default
   DESCRIPTION:=\
 	This package contains a wrapper module, that provides Wireless Extension \\\
 	support for the proprietary Broadcom wl module.
-  VERSION:=$(LINUX_VERSION)+$(BOARD)-$(PKG_RELEASE)
 endef
 
 define KernelPackage/wlcompat
diff --git a/package/zd1211/Makefile b/package/zd1211/Makefile
index 5d3292c04ec..292c9234145 100644
--- a/package/zd1211/Makefile
+++ b/package/zd1211/Makefile
@@ -31,7 +31,6 @@ define KernelPackage/zd1211
 	USB-WLAN-Chip.\\\
 	Initially contributed by ZyDAS, this driver is actively maintained by the \\\
 	open source community.
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,zd1211) 
 endef
-- 
GitLab