From 0434df7feedd13445734a39b7d58f6206c97927f Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 6 Jan 2009 15:56:30 +0000
Subject: [PATCH] add the make variable LIBGCC_S, which points to the correct
 libgcc ldflag (avr32 only has a static library, most targets use the dynamic
 one)

SVN-Revision: 13892
---
 rules.mk | 1 +
 1 file changed, 1 insertion(+)

diff --git a/rules.mk b/rules.mk
index 614feb6fc5f..31e073036d4 100644
--- a/rules.mk
+++ b/rules.mk
@@ -67,6 +67,7 @@ TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bi
 TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+LIBGCC_S=$(if $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so),-lgcc_s,$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.a))
 
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   -include $(TOOLCHAIN_DIR)/info.mk
-- 
GitLab