diff --git a/openwrt/Makefile b/openwrt/Makefile
index 89ca7d38b63bf69e640cd9fe91ef7f13549f4def..ed1e34db474f93dc62991a476afb813f300d52d6 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -132,7 +132,7 @@ dirclean: clean
 	rm -rf staging_dir_* toolchain_build_* tool_build
 
 distclean: dirclean config-clean
-	rm -rf dl .*config* .pkg* .prereq ccache_*
+	rm -rf dl .*config* .pkg* .prereq 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index eebc758224c6d811f761cbf6fb6470e05623fb0a..0ec5daf086e354ba60fc884dabbf7a0c2da2fcc7 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -60,7 +60,7 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif