diff --git a/target/linux/xburst/modules.mk b/target/linux/xburst/modules.mk
index 4604cd40d9042a94f7dbb135576e6d0812209bec..fc6d0c0e16aecbc3a6bcdbcbb3341265ed5bb746 100644
--- a/target/linux/xburst/modules.mk
+++ b/target/linux/xburst/modules.mk
@@ -31,7 +31,7 @@ define KernelPackage/sound-soc-xburst/default
   AUTOLOAD:=$(call AutoLoad,65,snd-soc-$(3))
 endef
 
-define KernelPackage/sound-soc-qi_lb60
+define KernelPackage/sound-soc-qilb60
 $(call KernelPackage/sound-soc-xburst/default,QI NanoNote,QI_LB60,qi-lb60,qi_lb60)
 endef
 
@@ -45,6 +45,6 @@ endef
 
 $(eval $(call KernelPackage,sound-soc-jz4740))
 $(eval $(call KernelPackage,sound-soc-jzcodec))
-$(eval $(call KernelPackage,sound-soc-qi_lb60))
+$(eval $(call KernelPackage,sound-soc-qilb60))
 $(eval $(call KernelPackage,sound-soc-n516))
 $(eval $(call KernelPackage,sound-soc-n526))
diff --git a/target/linux/xburst/qi_lb60/target.mk b/target/linux/xburst/qi_lb60/target.mk
index cd601a7751bc26bac937df8effd4e03eeaada898..0b2f578f4cb40fc7135343df7c4e1f8e3b0505fd 100644
--- a/target/linux/xburst/qi_lb60/target.mk
+++ b/target/linux/xburst/qi_lb60/target.mk
@@ -4,5 +4,5 @@ DEFAULT_PACKAGES += \
 	kmod-sound-soc-core \
 	kmod-sound-soc-jz4740 \
 	kmod-sound-soc-jzcodec \
-	kmod-sound-soc-qi_lb60 \
+	kmod-sound-soc-qilb60 \