diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index aa0816c9cc24e9772fa3db1ac86286b3d47c2149..96e5b7e1ccf824cfcad94b3be749dcae5cd03aff 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -120,6 +120,7 @@ ramips_setup_interfaces()
 	sap-g3200u3|\
 	sk-wb8|\
 	telco-electronics,x1|\
+	totolink,lr1200|\
 	unielec,u7621-06-256m-16m|\
 	unielec,u7621-06-512m-64m|\
 	vr500|\
diff --git a/target/linux/ramips/dts/TOTOLINK-LR1200.dts b/target/linux/ramips/dts/TOTOLINK-LR1200.dts
new file mode 100644
index 0000000000000000000000000000000000000000..81aa8db915cfa8e742a7b52240f9c928aebe3a20
--- /dev/null
+++ b/target/linux/ramips/dts/TOTOLINK-LR1200.dts
@@ -0,0 +1,156 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+	compatible = "totolink,lr1200", "mediatek,mt7628dan";
+	model = "TOTOLINK LR1200";
+
+	aliases {
+		led-boot = &led_sys;
+		led-failsafe = &led_sys;
+		led-running = &led_sys;
+		led-upgrade = &led_sys;
+	};
+
+	memory@0 {
+		device_type = "memory";
+		reg = <0x0 0x4000000>;
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		led_sys: sys {
+			label = "lr1200:blue:sys";
+			gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+		};
+		sms {
+			label = "lr1200:blue:sms";
+			gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
+		};
+		wifi {
+			label = "lr1200:blue:wifi";
+			gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+			linux,default-trigger = "phy0tpt";
+		};
+		3g {
+			label = "lr1200:blue:3g";
+			gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+		};
+		4g {
+			label = "lr1200:blue:4g";
+			gpios = <&gpio0 5 GPIO_ACTIVE_LOW>;
+		};
+		rssi1 {
+			label = "lr1200:blue:rssi1";
+			gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+		};
+		rssi2 {
+			label = "lr1200:blue:rssi2";
+			gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+		};
+		rssi3 {
+			label = "lr1200:blue:rssi3";
+			gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+		};
+		rssi4 {
+			label = "lr1200:blue:rssi4";
+			gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+		};
+	};
+
+	keys {
+		compatible = "gpio-keys-polled";
+		poll-interval = <20>;
+
+		reset {
+			label = "reset";
+			gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+			linux,code = <KEY_RESTART>;
+		};
+	};
+};
+
+&gpio1 {
+	gpio_modem_reset {
+		gpio-hog;
+		gpios = <13 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "modem-reset";
+	};
+};
+
+&pinctrl {
+	state_default: pinctrl0 {
+		gpio {
+			ralink,group = "gpio", "i2c", "i2s", "refclk", "uart1", "wdt", "wled_an";
+			ralink,function = "gpio";
+		};
+	};
+};
+
+&pcie {
+	status = "okay";
+};
+
+&pcie0 {
+	mt76@0,0 {
+		reg = <0x0000 0 0 0 0>;
+		mediatek,mtd-eeprom = <&factory 0x8000>;
+		ieee80211-freq-limit = <5000000 6000000>;
+	};
+};
+
+&wmac {
+	status = "okay";
+	ralink,mtd-eeprom = <&factory 0x4>;
+};
+
+&ethernet {
+	mtd-mac-address = <&factory 0x28>;
+};
+
+&spi0 {
+	status = "okay";
+
+	m25p80@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <40000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x0 0x30000>;
+				read-only;
+			};
+
+			partition@30000 {
+				label = "u-boot-env";
+				reg = <0x30000 0x10000>;
+				read-only;
+			};
+
+			factory: partition@40000 {
+				label = "factory";
+				reg = <0x40000 0x10000>;
+				read-only;
+			};
+
+			partition@50000 {
+				compatible = "denx,uimage";
+				label = "firmware";
+				reg = <0x50000 0x7b0000>;
+			};
+		};
+	};
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 4e6a5d1ca9b78175b023aafc1e1cf5082d384f38..2280a1a6180fc55f04a7d7e773551ae76258b1d0 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -183,6 +183,14 @@ define Device/skylab_skw92a
 endef
 TARGET_DEVICES += skylab_skw92a
 
+define Device/totolink_lr1200
+  DTS := TOTOLINK-LR1200
+  IMAGE_SIZE := 7872k
+  DEVICE_TITLE := TOTOLINK LR1200
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 uqmi
+endef
+TARGET_DEVICES += totolink_lr1200
+
 define Device/tplink_tl-wa801nd-v5
   $(Device/tplink)
   DTS := TL-WA801NDV5