diff --git a/config/Config-images.in b/config/Config-images.in
index 245aed098b36b462583a1669b742d138725bcf2f..a0c7b7a94db9298e642a132cf0020851dc7d418e 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -270,6 +270,7 @@ menu "Target Images"
 		int "Kernel partition size (in MB)"
 		depends on GRUB_IMAGES || USES_BOOT_PART
 		default 8 if TARGET_apm821xx_sata
+		default 20 if TARGET_brcm2708
 		default 16
 
 	config TARGET_ROOTFS_PARTSIZE
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index f4dd86767ca0e7cd28e04f50198e08d75a3860ed..11908f5c2f3cc5b29d1c30540f5a45635103789b 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
diff --git a/target/linux/brcm2708/image/Config.in b/target/linux/brcm2708/image/Config.in
deleted file mode 100644
index f7abd9d39db6297c9f9a6557e813bca8f88ba843..0000000000000000000000000000000000000000
--- a/target/linux/brcm2708/image/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-config BRCM2708_SD_BOOT_PARTSIZE
-	int "Boot (SD Card) filesystem partition size (in MB)"
-	depends on TARGET_brcm2708
-	default 20
-
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f2d8cec3265b88f9bb8c452ccc5c486b05b45059..cd00d7f3943709f57a69b90b97a11a068938de4b 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 FAT32_BLOCK_SIZE=1024
-FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_TARGET_KERNEL_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/Compile
 	$(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
@@ -44,7 +44,7 @@ endef
 
 define Build/sdcard-img
 	./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
-		$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+		$(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 endef
 
 ### Devices ###