From 1b216aa20a194e32ef6ff6ff028f58de49f29b20 Mon Sep 17 00:00:00 2001
From: Hamish Guthrie <hcg@openwrt.org>
Date: Wed, 18 Mar 2009 15:57:18 +0000
Subject: [PATCH] Add FEATURE ramdisk to be able to select the use of INITRAMFS
 for a sub-target

SVN-Revision: 14939
---
 Config.in                            | 2 +-
 scripts/metadata.pl                  | 1 +
 target/Config.in                     | 3 +++
 target/linux/ps3/petitboot/target.mk | 4 ++--
 4 files changed, 7 insertions(+), 3 deletions(-)

diff --git a/Config.in b/Config.in
index e412338921b..4d75896d8dd 100644
--- a/Config.in
+++ b/Config.in
@@ -15,7 +15,7 @@ source "target/Config.in"
 menu "Target Images"
 	config TARGET_ROOTFS_INITRAMFS
 		bool "ramdisk"
-		default n
+		default y if USES_INITRAMFS
 		depends LINUX_2_6
 		help
 		  Embed the rootfs into the kernel (initramfs)
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 3d9d68a654b..c341e652617 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -163,6 +163,7 @@ sub target_config_features(@) {
 		/tgz/ and $ret .= "\tselect USES_TGZ\n";
 		/cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
 		/fpu/ and $ret .= "\tselect HAS_FPU\n";
+		/ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n";
 	}
 	return $ret;
 }
diff --git a/target/Config.in b/target/Config.in
index 31f7a50b391..6506312b37a 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -29,6 +29,9 @@ config USB_SUPPORT
 config BIG_ENDIAN
 	bool
 
+config USES_INITRAMFS
+	bool
+
 config USES_SQUASHFS
 	bool
 
diff --git a/target/linux/ps3/petitboot/target.mk b/target/linux/ps3/petitboot/target.mk
index a3d84dde034..4b53f57b6b3 100644
--- a/target/linux/ps3/petitboot/target.mk
+++ b/target/linux/ps3/petitboot/target.mk
@@ -1,7 +1,7 @@
 BOARDNAME:=Petitboot
-FEATURES:=fpu
+FEATURES:=fpu ramdisk
 
-DEFAULT_PACKAGES+= dnsmasq
+DEFAULT_PACKAGES+= dnsmasq petitboot
 
 define Target/Description
 	Build Petitboot bootloader
-- 
GitLab