diff --git a/package/kernel/button-hotplug/Makefile b/package/kernel/button-hotplug/Makefile
index 348ea13401163eab27b79d881a8b8adf0099b398..10f6723903268a1361bd5b415ca7b8eb664f5728 100644
--- a/package/kernel/button-hotplug/Makefile
+++ b/package/kernel/button-hotplug/Makefile
@@ -16,6 +16,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/button-hotplug
   SUBMENU:=Other modules
   TITLE:=Button Hotplug driver
+  DEPENDS:=+kmod-input-core
   FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
   AUTOLOAD:=$(call AutoLoad,30,button-hotplug,1)
   KCONFIG:=