From 2271967f5747464c035b050ebd7e9e22b8582b1c Mon Sep 17 00:00:00 2001
From: Christian Lamparter <chunkeey@gmail.com>
Date: Thu, 27 Dec 2018 22:56:08 +0100
Subject: [PATCH] apm821xx: utilize build ARTIFACTs

The exported kernel dtbs can be build as artifacts.
This way, the MyBook Live's DTB is not generated twice.

While at it, give the artifacts their proper name.
For the wndr4700 use the "device-tree" partition name and
for the MyBook Live: "apollo3g.dtb" to match the mbl_boot.scr.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---
 target/linux/apm821xx/image/Makefile | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 75e85d18fb4..ba8f88cb9f8 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -198,7 +198,8 @@ define Device/netgear_wndr4700
   BLOCKSIZE := 128k
   DTB_SIZE := 131008
   IMAGE_SIZE := 24960k
-  IMAGES := factory.img sysupgrade.tar kernel.dtb
+  IMAGES := factory.img sysupgrade.tar
+  ARTIFACTS := device-tree.dtb
   KERNEL_SIZE := 3584k
   # append a fake/empty rootfs to fool netgear's uboot
   # CHECK_DNI_FIRMWARE_ROOTFS_INTEGRITY in do_chk_dniimg()
@@ -208,7 +209,7 @@ define Device/netgear_wndr4700
   IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
 		       netgear-dni | check-size $$$$(IMAGE_SIZE)
   IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
-  IMAGE/kernel.dtb := export-dtb | uImage none
+  ARTIFACT/device-tree.dtb := export-dtb | uImage none
   NETGEAR_BOARD_ID := WNDR4700
   NETGEAR_HW_ID := 29763875+128+256
   UBINIZE_OPTS := -E 5
@@ -231,11 +232,12 @@ define Device/wd_mybooklive
   KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
   BOOT_SIZE := 8
   IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
+  ARTIFACTS := kernel.dtb
   DEVICE_DTB := apollo3g.dtb
   FILESYSTEMS := ext4 squashfs
   IMAGE/factory.img.gz := boot-script | boot-img | hdd-img | gzip
-  IMAGE/kernel.dtb := export-dtb
   IMAGE/sysupgrade.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
+  ARTIFACT/apollo3g.dtb := export-dtb
 endef
 
 TARGET_DEVICES += wd_mybooklive
-- 
GitLab