From 23dd7867347ab4fd88592d0bfec1ce5a959c09f3 Mon Sep 17 00:00:00 2001
From: Mathias Kresin <dev@kresin.me>
Date: Tue, 16 Feb 2021 19:35:01 +0100
Subject: [PATCH] lantiq: set maximum kernel size

These boards have a fixed size kernel partition but do not limit the
kernel size during image building.

Disable image building for both boards as well, since the kernel of the
last release as well as master are to big to fit into the 2 MByte kernel
partition.

Signed-off-by: Mathias Kresin <dev@kresin.me>
---
 target/linux/lantiq/image/ar9.mk    | 2 ++
 target/linux/lantiq/image/danube.mk | 2 ++
 2 files changed, 4 insertions(+)

diff --git a/target/linux/lantiq/image/ar9.mk b/target/linux/lantiq/image/ar9.mk
index ad061b27762..a973c90beb3 100644
--- a/target/linux/lantiq/image/ar9.mk
+++ b/target/linux/lantiq/image/ar9.mk
@@ -34,6 +34,7 @@ define Device/bt_homehub-v3a
   DEVICE_VARIANT := Type A
   BOARD_NAME := BTHOMEHUBV3A
   SOC := ar9
+  KERNEL_SIZE := 2048k
   DEVICE_PACKAGES := kmod-usb-dwc2 \
 	kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
 	kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
@@ -42,6 +43,7 @@ define Device/bt_homehub-v3a
 	kmod-ath9k kmod-owl-loader wpad-basic-wolfssl \
 	uboot-envtools
   SUPPORTED_DEVICES += BTHOMEHUBV3A
+  DEFAULT := n
 endef
 TARGET_DEVICES += bt_homehub-v3a
 
diff --git a/target/linux/lantiq/image/danube.mk b/target/linux/lantiq/image/danube.mk
index ea22081d65b..73ec27222a6 100644
--- a/target/linux/lantiq/image/danube.mk
+++ b/target/linux/lantiq/image/danube.mk
@@ -188,6 +188,7 @@ define Device/bt_homehub-v2b
   DEVICE_VARIANT := Type B
   BOARD_NAME := BTHOMEHUBV2B
   SOC := danube
+  KERNEL_SIZE := 2048k
   DEVICE_PACKAGES := kmod-usb-dwc2 \
 	kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
 	kmod-ltq-adsl-danube-fw-a kmod-ltq-atm-danube \
@@ -195,6 +196,7 @@ define Device/bt_homehub-v2b
 	ltq-adsl-app ppp-mod-pppoa \
 	kmod-ath9k kmod-owl-loader wpad-basic-wolfssl
   SUPPORTED_DEVICES += BTHOMEHUBV2B
+  DEFAULT := n
 endef
 TARGET_DEVICES += bt_homehub-v2b
 
-- 
GitLab