diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 55e1a0b2dc1250bdf2eddae3d7ffc88cd80f4da5..4f6d8f529e4e40012be9ec6a20b0ff8356fa2794 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -87,7 +87,9 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
   SUPPORTED_DEVICES = $$(DEVICE_DTS)
+  UBOOT :=
 endef
+DEVICE_VARS += UBOOT
 
 define Device/UBI
   IMAGES := sysupgrade.bin
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index aa56a721a803a1b068009459a917c26a7509f319..d9defe880de6ddf0756b44688f8b4ad75db6b11e 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -158,7 +158,6 @@ define Device/turris-omnia
   IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
   IMAGE_NAME = $$(2)
   DEVICE_DTS := armada-385-turris-omnia
-  UBOOT :=
 endef
 TARGET_DEVICES += turris-omnia