diff --git a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/P2812HNUF1.dts b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/P2812HNUF1.dts
index 911a2d6afee0ef878d4ec9b8ea8e775b6b7ffcad..d907d64c8cbdbd2da8d08e8099598860f7dc0821 100644
--- a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/P2812HNUF1.dts
+++ b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/P2812HNUF1.dts
@@ -47,11 +47,11 @@
 			};
 			partition@60000 {
 				label = "kernel";
-				reg = <0x60000 0x200000>;
+				reg = <0x60000 0x300000>;
 			};
-			partition@260000 {
+			partition@360000 {
 				label = "ubi";
-				reg = <0x260000 0x7da0000>;
+				reg = <0x360000 0x7ca0000>;
 			};
 		};
 	};
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b59acf4ddcb6abc06b00909932b6a262aaf9c7ef..7e328bf2be897d2791d55085defe8df981a193ef 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -553,6 +553,7 @@ define Device/zyxel_p-2812hnu-f1
   DEVICE_DTS := P2812HNUF1
   DEVICE_TITLE := ZyXEL P-2812HNU-F1
   DEVICE_PACKAGES := kmod-rt2800-pci wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport
+  KERNEL_SIZE := 3072k
   SUPPORTED_DEVICES += P2812HNUF1
 endef
 TARGET_DEVICES += zyxel_p-2812hnu-f1