From 4551f2bfcc97fb2a614b56e27e9b8ef7e814c194 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Sun, 3 Jul 2011 17:37:31 +0000
Subject: [PATCH] add menuconfig option to enable log files during build
 process

SVN-Revision: 27403
---
 Config.in | 5 +++++
 rules.mk  | 4 ++++
 2 files changed, 9 insertions(+)

diff --git a/Config.in b/Config.in
index 61d87a0a1ce..f36221cee66 100644
--- a/Config.in
+++ b/Config.in
@@ -425,6 +425,11 @@ menuconfig DEVEL
 		  In this instance, the --refererence option of git clone will
 		  be used thus creating a quick local clone of your repo.
 
+	config BUILD_LOG
+		bool "Enable log files during build process" if DEVEL
+		help
+		  If enabled log files will be written to the ./log directory
+
 menuconfig TARGET_OPTIONS
 	bool "Target Options"  if DEVEL
 
diff --git a/rules.mk b/rules.mk
index 7be2d6195d9..874066e3785 100644
--- a/rules.mk
+++ b/rules.mk
@@ -239,6 +239,10 @@ else
   TAR_OPTIONS:=-xf -
 endif
 
+ifeq ($(CONFIG_BUILD_LOG),y)
+  BUILD_LOG:=1
+endif
+
 define shvar
 V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 endef
-- 
GitLab