From 493b7c7f3cb300944453b110f5098a950053fd4b Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 23 Sep 2012 09:59:56 +0000
Subject: [PATCH] x86: avoid using grub prepare when using grub2

SVN-Revision: 33525
---
 target/linux/x86/image/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ebe07885930..547f0839fdf 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -237,7 +237,7 @@ endef
 define Image/Prepare
 	$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
 	$(call Image/Prepare/bootscript)
-	$(call Image/Prepare/grub)
+	$(call Image/Prepare/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub))
 endef
 
 define Image/Build
-- 
GitLab