diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index fa70cfde3ed75f0318c67e04006620ac281dc88c..d4fdab16036dabcc2e290c1c3781a928abf41d86 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .99
+LINUX_VERSION-5.4 = .100
 LINUX_VERSION-5.10 = .18
 
-LINUX_KERNEL_HASH-5.4.99 = 5bdad12c69253d30d836dd51e0b2a9a04a6749cc6b4b2412561a1efcb1351a27
+LINUX_KERNEL_HASH-5.4.100 = 795d681aa60822bcf4f2f6c28b4411e1b09d5ca37b85a647967649d1ab3b240a
 LINUX_KERNEL_HASH-5.10.18 = 3bc1ee2b1bf73b5ba936721953f3f9599fd165cef906cd5163c68d23cb9bb611
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/generic/pending-5.4/491-ubi-auto-create-ubiblock-device-for-rootfs.patch b/target/linux/generic/pending-5.4/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
index 88d609d9967b59a7d4ea3299e2aa1bdf053da2f2..a2b48fd4fc70a5a40ea6f977c9473854d7766c71 100644
--- a/target/linux/generic/pending-5.4/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
+++ b/target/linux/generic/pending-5.4/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
@@ -56,7 +56,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  static void ubiblock_remove_all(void)
  {
  	struct ubiblock *next;
-@@ -684,6 +722,10 @@ int __init ubiblock_init(void)
+@@ -684,6 +725,10 @@ int __init ubiblock_init(void)
  	 */
  	ubiblock_create_from_param();
  
diff --git a/target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch b/target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch
index 86eb5ef9536ac483706b371c9c6d636f9b8df156..d203c754600c29e9a8dbabfd8eb27d8b4faf3a97 100644
--- a/target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch
+++ b/target/linux/mediatek/patches-5.4/0601-net-dsa-propagate-resolved-link-config-via-mac_link_.patch
@@ -103,7 +103,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  }
 --- a/include/net/dsa.h
 +++ b/include/net/dsa.h
-@@ -401,7 +401,9 @@ struct dsa_switch_ops {
+@@ -406,7 +406,9 @@ struct dsa_switch_ops {
  	void	(*phylink_mac_link_up)(struct dsa_switch *ds, int port,
  				       unsigned int mode,
  				       phy_interface_t interface,
@@ -128,7 +128,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/net/dsa/dsa_priv.h
 +++ b/net/dsa/dsa_priv.h
-@@ -180,9 +180,11 @@ void dsa_port_phylink_mac_link_down(stru
+@@ -192,9 +192,11 @@ void dsa_port_phylink_mac_link_down(stru
  				    unsigned int mode,
  				    phy_interface_t interface);
  void dsa_port_phylink_mac_link_up(struct phylink_config *config,