From 5287ac2dfbd0393e23e35e415ddf37f42df9b58e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
Date: Tue, 3 Sep 2019 13:01:50 +0200
Subject: [PATCH] brcm2708: restore UART on RPi 0W, 3B, 3B+ and 4B
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Disable Bluetooth and restore UART to GPIOs 14 & 15.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
---
 target/linux/brcm2708/image/Makefile               |  1 +
 .../linux/brcm2708/image/config-bcm2711-arm64.txt  |  6 ++++++
 target/linux/brcm2708/image/config.txt             |  6 ++++++
 target/linux/brcm2708/image/distroconfig.txt       | 14 ++++++++++++++
 4 files changed, 27 insertions(+)
 create mode 100644 target/linux/brcm2708/image/distroconfig.txt

diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f1a4bb8dc49..97f127d3077 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -28,6 +28,7 @@ define Build/boot-common
 	mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
 	mcopy -i $@.boot cmdline.txt ::
 	mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
+	mcopy -i $@.boot distroconfig.txt ::
 	mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
 	$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
 	mmd -i $@.boot ::/overlays
diff --git a/target/linux/brcm2708/image/config-bcm2711-arm64.txt b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
index 1af8ed0dfee..984aab585e8 100644
--- a/target/linux/brcm2708/image/config-bcm2711-arm64.txt
+++ b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
@@ -9,3 +9,9 @@
 
 # Force aarch64
 arm_64bit=1
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
diff --git a/target/linux/brcm2708/image/config.txt b/target/linux/brcm2708/image/config.txt
index 0b963a99ae0..f8ca1bf2d49 100644
--- a/target/linux/brcm2708/image/config.txt
+++ b/target/linux/brcm2708/image/config.txt
@@ -6,3 +6,9 @@
 # For overclocking and various other settings, see:
 # https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
 ################################################################################
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
diff --git a/target/linux/brcm2708/image/distroconfig.txt b/target/linux/brcm2708/image/distroconfig.txt
new file mode 100644
index 00000000000..54cf44346fa
--- /dev/null
+++ b/target/linux/brcm2708/image/distroconfig.txt
@@ -0,0 +1,14 @@
+################################################################################
+# Bootloader configuration - distroconfig.txt
+################################################################################
+
+# Restore PL011 (ttyAMA0) to GPIOs 14 & 15, instead of Mini UART (ttyS0).
+# Mini UART is disabled by default unless "enable_uart=1" is specified,
+#  which changes the core frequency to a fixed value and impacts performance.
+# See https://www.raspberrypi.org/documentation/configuration/uart.md
+[pi0w]
+dtoverlay=disable-bt
+[pi3]
+dtoverlay=disable-bt
+[pi4]
+dtoverlay=disable-bt
-- 
GitLab