From 5ec22097344e7f57a1b0e9332dd87051627cea18 Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Tue, 5 Jun 2012 13:40:38 +0000
Subject: [PATCH] refresh generic patches

SVN-Revision: 32059
---
 .../patches-3.3/653-disable_netlink_trim.patch   |  2 +-
 .../generic/patches-3.3/729-phy-tantos.patch     | 16 ++++++----------
 .../811-pci_disable_usb_common_quirks.patch      |  4 ++--
 .../patches-3.3/920-unable_to_open_console.patch |  2 +-
 .../patches-3.3/921-use_preinit_as_init.patch    |  2 +-
 5 files changed, 11 insertions(+), 15 deletions(-)

diff --git a/target/linux/generic/patches-3.3/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.3/653-disable_netlink_trim.patch
index c6c7c75a9e4..ffa6502cd65 100644
--- a/target/linux/generic/patches-3.3/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.3/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -854,25 +854,7 @@ void netlink_detachskb(struct sock *sk, 
+@@ -854,25 +854,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
diff --git a/target/linux/generic/patches-3.3/729-phy-tantos.patch b/target/linux/generic/patches-3.3/729-phy-tantos.patch
index 203b3e6ab84..890d40c4d6a 100644
--- a/target/linux/generic/patches-3.3/729-phy-tantos.patch
+++ b/target/linux/generic/patches-3.3/729-phy-tantos.patch
@@ -1,8 +1,6 @@
-Index: linux-3.3.7/drivers/net/phy/Kconfig
-===================================================================
---- linux-3.3.7.orig/drivers/net/phy/Kconfig	2012-05-27 18:09:00.129697447 +0200
-+++ linux-3.3.7/drivers/net/phy/Kconfig	2012-05-29 18:31:44.462611635 +0200
-@@ -207,3 +207,7 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -206,3 +206,7 @@ endif # PHYLIB
  config MICREL_KS8995MA
  	tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
  	depends on SPI
@@ -10,11 +8,9 @@ Index: linux-3.3.7/drivers/net/phy/Kconfig
 +config PSB6970_PHY
 +	tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
 +	select SWCONFIG
-Index: linux-3.3.7/drivers/net/phy/Makefile
-===================================================================
---- linux-3.3.7.orig/drivers/net/phy/Makefile	2012-05-27 18:09:00.129697447 +0200
-+++ linux-3.3.7/drivers/net/phy/Makefile	2012-05-29 18:30:59.286610634 +0200
-@@ -28,6 +28,7 @@
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY)	+= rtl8366rb
  obj-$(CONFIG_RTL8367_PHY)	+= rtl8367.o
  obj-$(CONFIG_LSI_ET1011C_PHY)	+= et1011c.o
  obj-$(CONFIG_MICREL_PHY)	+= micrel.o
diff --git a/target/linux/generic/patches-3.3/811-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-3.3/811-pci_disable_usb_common_quirks.patch
index d4fa69d2390..ce50afa8e49 100644
--- a/target/linux/generic/patches-3.3/811-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-3.3/811-pci_disable_usb_common_quirks.patch
@@ -1,7 +1,7 @@
 
 --- a/drivers/usb/host/pci-quirks.c
 +++ b/drivers/usb/host/pci-quirks.c
-@@ -431,6 +431,8 @@ reset_needed:
+@@ -432,6 +432,8 @@ reset_needed:
  }
  EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
  
@@ -10,7 +10,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
  	u16 cmd;
-@@ -898,3 +900,5 @@ static void __devinit quirk_usb_early_ha
+@@ -928,3 +930,5 @@ static void __devinit quirk_usb_early_ha
  	pci_disable_device(pdev);
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
diff --git a/target/linux/generic/patches-3.3/920-unable_to_open_console.patch b/target/linux/generic/patches-3.3/920-unable_to_open_console.patch
index f08a59f82e5..11f67dc2c92 100644
--- a/target/linux/generic/patches-3.3/920-unable_to_open_console.patch
+++ b/target/linux/generic/patches-3.3/920-unable_to_open_console.patch
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -815,7 +815,7 @@ static int __init kernel_init(void * unu
+@@ -816,7 +816,7 @@ static int __init kernel_init(void * unu
  
  	/* Open the /dev/console on the rootfs, this should never fail */
  	if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
diff --git a/target/linux/generic/patches-3.3/921-use_preinit_as_init.patch b/target/linux/generic/patches-3.3/921-use_preinit_as_init.patch
index 395cb6ddbe2..a71251dcd7f 100644
--- a/target/linux/generic/patches-3.3/921-use_preinit_as_init.patch
+++ b/target/linux/generic/patches-3.3/921-use_preinit_as_init.patch
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -777,10 +777,7 @@ static noinline int init_post(void)
+@@ -774,10 +774,7 @@ static noinline int init_post(void)
  		printk(KERN_WARNING "Failed to execute %s.  Attempting "
  					"defaults...\n", execute_command);
  	}
-- 
GitLab