From 719e106855399b0679d174f2368c3e3b15b90d30 Mon Sep 17 00:00:00 2001
From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Fri, 24 Jan 2020 18:48:47 +0100
Subject: [PATCH] lantiq: fix setting SOC to DEFAULT_SOC

This adds the missing assignment of DEFAULT_SOC to the SOC variable
by default.

Fixes: 09ee51c614d9 ("lantiq: define SOC only once for uniform targets")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/lantiq/image/Makefile | 1 +
 1 file changed, 1 insertion(+)

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index d385cdca7b6..4cd9b4ab486 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -63,6 +63,7 @@ define Device/Default
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   FILESYSTEMS := squashfs
   IMAGE_SIZE :=
+  SOC := $(DEFAULT_SOC)
   DEVICE_DTS = $$(SOC)_$(1)
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
-- 
GitLab