From 73c1dd947351573567541b34186aa381f6546bd8 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 15 Mar 2011 19:58:32 +0000
Subject: [PATCH] build: move the CCACHE_DIR to the build targets so that it
 doesn't interfere with a host ccache setup

SVN-Revision: 26181
---
 include/package.mk | 1 +
 rules.mk           | 2 --
 2 files changed, 1 insertion(+), 2 deletions(-)

diff --git a/include/package.mk b/include/package.mk
index 1cf4d64cc90..2ebd66d119c 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -90,6 +90,7 @@ define Build/Exports/Default
   $(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
   $(1) : export PKG_CONFIG_PATH:=$$(PKG_CONFIG_PATH)
   $(1) : export PKG_CONFIG_LIBDIR:=$$(PKG_CONFIG_PATH)
+  $(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache
 endef
 Build/Exports=$(Build/Exports/Default)
 
diff --git a/rules.mk b/rules.mk
index c2b0dcaff9b..2d56c436ed2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -178,8 +178,6 @@ INSTALL_DATA:=install -m0644
 INSTALL_CONF:=install -m0600
 
 ifneq ($(CONFIG_CCACHE),)
-  # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
   TARGET_CXX:= ccache $(TARGET_CXX)
 endif
-- 
GitLab