From 73f3ad1df2e1d33d3d5aae4fd2093aa80406cc4a Mon Sep 17 00:00:00 2001
From: Paul Spooren <mail@aparcar.org>
Date: Tue, 11 Feb 2020 17:27:24 -1000
Subject: [PATCH] build: fix empty SUBTARGET in json files

Some targets like kirkwood or omap don't use a subtarget which results
in a malformed JSON info file.

Instead of having a valid value like `"target": "ath79/tiny"` for these
targets the value is `"target": "kirkwood/"`.

This patch uses the same if condition to use `generic` if the subtarget
is empty.

Tested for the kirkwood target.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 include/image.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/image.mk b/include/image.mk
index 46d592e8dca..fd04d4020bf 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -588,7 +588,7 @@ define Device/Build/image
 		DEVICE_ALT2_VARIANT="$(DEVICE_ALT2_VARIANT)" \
 		DEVICE_TITLE="$(DEVICE_TITLE)" \
 		TARGET="$(BOARD)" \
-		SUBTARGET="$(SUBTARGET)" \
+		SUBTARGET="$(if $(SUBTARGET),$(SUBTARGET),generic)" \
 		VERSION_NUMBER="$(VERSION_NUMBER)" \
 		VERSION_CODE="$(VERSION_CODE)" \
 		SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
-- 
GitLab