From 77e27e0f5354e3155c9951a0d5e570e36d548f1c Mon Sep 17 00:00:00 2001
From: Kevin Schmidt <kevin.patrick.schmidt@googlemail.com>
Date: Sat, 23 Nov 2019 22:18:32 +0100
Subject: [PATCH] lantiq: enable 5ghz wifi on VR200/VR200v

Enable mt76 driver on VR200/VR200v.

Signed-off-by: Kevin Schmidt <kevin.patrick.schmidt@googlemail.com>
---
 .../boot/dts/lantiq/vr9_tplink_vr200.dtsi     | 21 ++++++++++++++++++-
 target/linux/lantiq/image/tp-link.mk          |  4 ++--
 2 files changed, 22 insertions(+), 3 deletions(-)

diff --git a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
index 93178da7e2b..77b4f0defbd 100644
--- a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
+++ b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
@@ -112,6 +112,25 @@
 	};
 };
 
+&pcie0 {
+	pcie@0 {
+		reg = <0 0 0 0 0>;
+		#interrupt-cells = <1>;
+		#size-cells = <2>;
+		#address-cells = <3>;
+		device_type = "pci";
+
+		wifi@0,0 {
+			reg = <0 0 0 0 0>;
+			mediatek,mtd-eeprom = <&radio 0x0000>;
+			big-endian;
+			ieee80211-freq-limit = <5000000 6000000>;
+			mtd-mac-address = <&romfile 0xf100>;
+			mtd-mac-address-increment = <2>;
+		};
+	};
+};
+
 &pci0 {
 	status = "okay";
 	gpio-reset = <&gpio 21 GPIO_ACTIVE_HIGH>;
@@ -166,7 +185,7 @@
 				read-only;
 			};
 
-			partition@ff0000 {
+			radio: partition@ff0000 {
 				reg = <0xff0000 0x10000>;
 				label = "radio";
 				read-only;
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index 56a7e5ca57d..fa98f31f59e 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -47,7 +47,7 @@ define Device/tplink_vr200
   TPLINK_HWID := 0x63e64801
   TPLINK_HWREV := 0x53
   IMAGE_SIZE := 15808k
-  DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES:= kmod-mt76x0e wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += VR200
 endef
 TARGET_DEVICES += tplink_vr200
@@ -60,7 +60,7 @@ define Device/tplink_vr200v
   TPLINK_HWID := 0x73b70801
   TPLINK_HWREV := 0x2f
   IMAGE_SIZE := 15808k
-  DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-ltq-tapi kmod-ltq-vmmc
+  DEVICE_PACKAGES:= kmod-mt76x0e wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-ltq-tapi kmod-ltq-vmmc
   SUPPORTED_DEVICES += VR200v
 endef
 TARGET_DEVICES += tplink_vr200v
-- 
GitLab