diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e6fbc1dbf8b511de2faeee5c0f18743c2b9872f0..3541ca8b54d449ba3aecaab0d7b87ae79ff58ee4 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -584,6 +584,10 @@ TARGET_DEVICES += bt_homehub-v5a
 define Device/netgear_dm200
   DEVICE_DTS := DM200
   IMAGES := sysupgrade.bin factory.img
+  IMAGE/sysupgrade.bin := append-kernel | \
+	pad-offset 64k 64 | append-uImage-fakeroot-hdr | \
+	pad-offset 64k 64 | append-uImage-fakeroot-hdr | \
+	append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.img := $$(IMAGE/sysupgrade.bin) | netgear-dni
   IMAGE_SIZE := 7872k
   DEVICE_TITLE := Netgear DM200