From 8cac8572897c28e902218b445aa9bed82c40989f Mon Sep 17 00:00:00 2001
From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Date: Wed, 12 Sep 2018 08:24:37 +0100
Subject: [PATCH] iproute2: q_cake: Add printing of no-split-gso option

When the GSO splitting was turned into dual split-gso/no-split-gso options,
the printing of the latter was left out. Add that, so output is consistent
with the options passed

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
---
 package/network/utils/iproute2/Makefile                       | 2 +-
 .../network/utils/iproute2/patches/190-add-cake-to-tc.patch   | 4 +++-
 2 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index ac313107832..5ed9556043d 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.18.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
diff --git a/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
index fa09b4d8675..f61168c696f 100644
--- a/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
@@ -854,7 +854,7 @@
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,799 @@
+@@ -0,0 +1,801 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
@@ -1381,6 +1381,8 @@
 +
 +	if (split_gso)
 +		print_string(PRINT_FP, NULL, "split-gso ", NULL);
++	else
++		print_string(PRINT_FP, NULL, "no-split-gso ", NULL);
 +	print_bool(PRINT_JSON, "split_gso", NULL, split_gso);
 +
 +	if (interval)
-- 
GitLab