From 8f1764b98a2251c5780455ac131b38ecf9a53bca Mon Sep 17 00:00:00 2001
From: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Date: Wed, 13 Sep 2017 11:51:20 -0700
Subject: [PATCH] uboot-at91: Add support for SAMA5D3 Xplained board

Add support for SAMA5D3 Xplained board and options to select & build
u-boot configs for different media storage.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
---
 package/boot/uboot-at91/Makefile | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)

diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 68e4ba498bc..2c95377b0fb 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -30,9 +30,23 @@ define U-Boot/at91sam9x5ek_nandflash
   BUILD_SUBTARGET:=legacy
 endef
 
+define uboot/sama5d3_xplained_nandflash
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
 UBOOT_TARGETS := \
 	at91sam9m10g45ek_nandflash \
-	at91sam9x5ek_nandflash
+	at91sam9x5ek_nandflash \
+    sama5d3_xplained_nandflash \
+    sama5d3_xplained_mmc
 
 define Build/Compile
 	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-- 
GitLab