From 97ea9e3c2aeefd0c782628797260f0e4d1e5937d Mon Sep 17 00:00:00 2001
From: Steven Barth <cyrus@openwrt.org>
Date: Tue, 11 Mar 2014 14:58:00 +0000
Subject: [PATCH] iptables/netfilter: add connlimit to conntrack-extra

SVN-Revision: 39878
---
 include/netfilter.mk                    | 1 +
 package/network/utils/iptables/Makefile | 1 +
 2 files changed, 2 insertions(+)

diff --git a/include/netfilter.mk b/include/netfilter.mk
index 305f28e0879..1ecbe02eab2 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -72,6 +72,7 @@ $(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNTRACK, $(P_XT)x
 # conntrack-extra
 
 $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_CONNBYTES, $(P_XT)xt_connbytes))
+$(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_CONNLIMIT, $(P_XT)xt_connlimit))
 $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_CONNMARK, $(P_XT)xt_connmark))
 $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_XT)xt_helper))
 $(eval $(call nf_add,IPT_CONNTRACK_EXTRA,CONFIG_NETFILTER_XT_MATCH_RECENT, $(P_XT)xt_recent))
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 50b1754c519..fd8477252f5 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -103,6 +103,7 @@ Extra iptables extensions for connection tracking.
 
  Matches:
   - connbytes
+  - connlimit
   - connmark
   - recent
   - helper
-- 
GitLab