diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 97f127d3077be53c72c379aa05e22e4b62aea706..01d1bf585f3f4089db11529654c23df3ed729cfd 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -27,7 +27,7 @@ define Build/boot-common
 	mcopy -i $@.boot $(KDIR)/COPYING.linux ::
 	mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
 	mcopy -i $@.boot cmdline.txt ::
-	mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
+	mcopy -i $@.boot config.txt ::
 	mcopy -i $@.boot distroconfig.txt ::
 	mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
 	$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
@@ -68,7 +68,6 @@ define Device/Default
   IMAGES := factory.img.gz sysupgrade.img.gz
   IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | sdcard-img | gzip | append-metadata
   IMAGE/factory.img.gz := boot-common | boot-2708 | sdcard-img | gzip
-  BOOT_CONFIG := config.txt
 endef
 
 define Device/rpi
@@ -141,7 +140,6 @@ define Device/rpi-4
 	kmod-brcmfmac wpad-basic
   IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
   IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
-  BOOT_CONFIG := config-bcm2711-arm64.txt
 endef
 ifeq ($(SUBTARGET),bcm2711)
   TARGET_DEVICES += rpi-4
diff --git a/target/linux/brcm2708/image/config-bcm2711-arm64.txt b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
deleted file mode 100644
index 984aab585e8245797dfacf3f8c002fa95c567ed7..0000000000000000000000000000000000000000
--- a/target/linux/brcm2708/image/config-bcm2711-arm64.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-################################################################################
-# Bootloader configuration - config.txt
-################################################################################
-
-################################################################################
-# For overclocking and various other settings, see:
-# https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
-################################################################################
-
-# Force aarch64
-arm_64bit=1
-
-# OpenWrt config
-include distroconfig.txt
-
-[all]
-# Place your custom settings here.