From a0a91963af6b96dc648ad4fe56ce4415ccb74cbd Mon Sep 17 00:00:00 2001
From: Steven Barth <cyrus@openwrt.org>
Date: Wed, 30 Jan 2013 09:05:53 +0000
Subject: [PATCH] 6in4: work around hanging wget process

SVN-Revision: 35408
---
 package/network/ipv6/6in4/Makefile      | 2 +-
 package/network/ipv6/6in4/files/6in4.sh | 6 ++++--
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index cddf0372e5d..7090234358d 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=13
+PKG_VERSION:=14
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index ef253223461..e27e86ef085 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -65,8 +65,10 @@ proto_6in4_setup() {
 		local max=3
 
 		while [ $((++try)) -le $max ]; do
-			wget -qO/dev/null "$url" 2>/dev/null && break
-			sleep 1
+			( wget -qO/dev/null "$url" 2>/dev/null ) &
+			local pid=$!
+			( sleep 5; kill $pid 2>/dev/null ) &
+			wait $pid && break
 		done
 	}
 }
-- 
GitLab