diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index d4fdab16036dabcc2e290c1c3781a928abf41d86..d6bb2061ca99764ea013ed389404b05f2edd28ca 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .100
+LINUX_VERSION-5.4 = .101
 LINUX_VERSION-5.10 = .18
 
-LINUX_KERNEL_HASH-5.4.100 = 795d681aa60822bcf4f2f6c28b4411e1b09d5ca37b85a647967649d1ab3b240a
+LINUX_KERNEL_HASH-5.4.101 = 4e118c072dbe3209ddeaff32ecc558f7e809d54e661550342079f1ee76d9349d
 LINUX_KERNEL_HASH-5.10.18 = 3bc1ee2b1bf73b5ba936721953f3f9599fd165cef906cd5163c68d23cb9bb611
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/layerscape/patches-5.4/701-net-0273-net-dsa-ocelot-add-tsn-support-for-felix-switch.patch b/target/linux/layerscape/patches-5.4/701-net-0273-net-dsa-ocelot-add-tsn-support-for-felix-switch.patch
index c797963560bac1e71671c8623c4328584bfa7e2a..72b101bfb0bc5ae69ad72249593ca238934f1c25 100644
--- a/target/linux/layerscape/patches-5.4/701-net-0273-net-dsa-ocelot-add-tsn-support-for-felix-switch.patch
+++ b/target/linux/layerscape/patches-5.4/701-net-0273-net-dsa-ocelot-add-tsn-support-for-felix-switch.patch
@@ -648,7 +648,7 @@ Signed-off-by: Xiaoliang Yang <xiaoliang.yang_1@nxp.com>
  static const u32 vsc9959_gcb_regmap[] = {
 --- a/include/net/dsa.h
 +++ b/include/net/dsa.h
-@@ -554,6 +554,7 @@ struct dsa_switch_ops {
+@@ -559,6 +559,7 @@ struct dsa_switch_ops {
  	 */
  	netdev_tx_t (*port_deferred_xmit)(struct dsa_switch *ds, int port,
  					  struct sk_buff *skb);
diff --git a/target/linux/layerscape/patches-5.4/701-net-0381-net-dsa-Pass-pcs_poll-flag-from-driver-to-PHYLINK.patch b/target/linux/layerscape/patches-5.4/701-net-0381-net-dsa-Pass-pcs_poll-flag-from-driver-to-PHYLINK.patch
index bdd58022072f968cc0bae96d6fa31b223c2810cd..fe2ceee8d46bb1a861d436e08ca6dba08bd0f75d 100644
--- a/target/linux/layerscape/patches-5.4/701-net-0381-net-dsa-Pass-pcs_poll-flag-from-driver-to-PHYLINK.patch
+++ b/target/linux/layerscape/patches-5.4/701-net-0381-net-dsa-Pass-pcs_poll-flag-from-driver-to-PHYLINK.patch
@@ -24,7 +24,7 @@ on touch") which was merged in v5.4-rc3.
 
 --- a/include/net/dsa.h
 +++ b/include/net/dsa.h
-@@ -286,6 +286,11 @@ struct dsa_switch {
+@@ -291,6 +291,11 @@ struct dsa_switch {
  	 */
  	bool			vlan_filtering;