diff --git a/include/autotools.mk b/include/autotools.mk
index 7797031fd6143376a702ac9794d670f60d965065..7fe376cc156b7e5401192288ab1be614e009f078 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -38,6 +38,7 @@ define autoreconf
 				[ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
 				touch NEWS AUTHORS COPYING ChangeLog; \
 				$(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+					$(if $(word 2,$(3)),--no-recursive) \
 					-B $(STAGING_DIR_HOST)/share/aclocal \
 					$(patsubst %,-I %,$(5)) \
 					$(patsubst %,-I %,$(4)) $(4) || true; \