From ab2bdf2505ed6bf1c3c2544c08c0e845aef19fba Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Sat, 30 Dec 2006 14:44:27 +0000
Subject: [PATCH] only squash owners, not permissions, when generating ext2
 images

SVN-Revision: 5934
---
 include/image.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/image.mk b/include/image.mk
index 1c36327c61f..702434ec861 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-		$(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+		$(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
 		$(call Image/Build,ext2)
   endef
 endif
-- 
GitLab