From b4e49ad8f0c75f2c3f22e6bc8a8c1af7fddff258 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Mon, 14 Sep 2015 14:03:21 +0000
Subject: [PATCH] tools/xz: disable shared library

Force a static build of the xz utilities in order to avoid the dependency on a
shared liblzma.so which might collide with the distro version.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 46907
---
 tools/xz/Makefile | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index e2666679578..d1f10081aeb 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+	--enable-static=yes \
+	--enable-shared=no \
+
 define Host/Install
 	+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
-- 
GitLab