From cd40e47a4874e3ef8cd19f057aa3fcac3983d0d7 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Thu, 14 Mar 2013 18:42:57 +0000
Subject: [PATCH] make hcd driver work with v3.8

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 36019
---
 package/platform/lantiq/ltq-hcd/Makefile            | 4 +++-
 package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c | 2 ++
 2 files changed, 5 insertions(+), 1 deletion(-)

diff --git a/package/platform/lantiq/ltq-hcd/Makefile b/package/platform/lantiq/ltq-hcd/Makefile
index 6f654b4aa44..74218c887b4 100644
--- a/package/platform/lantiq/ltq-hcd/Makefile
+++ b/package/platform/lantiq/ltq-hcd/Makefile
@@ -23,13 +23,14 @@ define KernelPackage/ltq-hcd-template
   VARIANT:=$(1)
   DEPENDS:=@TARGET_lantiq_$(2) +kmod-usb-core
   FILES:=$(PKG_BUILD_DIR)/ltq_hcd_$(1).ko
-  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1))
+  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1),1)
 endef
 
 KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,ase)
 KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,danube,xway)
 KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,xway)
 KernelPackage/ltq-hcd-vr9=$(call KernelPackage/ltq-hcd-template,vr9,xway)
+KernelPackage/ltq-hcd-ar10=$(call KernelPackage/ltq-hcd-template,ar10,xway)
 
 define Build/Prepare
 	$(INSTALL_DIR) $(PKG_BUILD_DIR)
@@ -49,3 +50,4 @@ $(eval $(call KernelPackage,ltq-hcd-ase))
 $(eval $(call KernelPackage,ltq-hcd-danube))
 $(eval $(call KernelPackage,ltq-hcd-ar9))
 $(eval $(call KernelPackage,ltq-hcd-vr9))
+$(eval $(call KernelPackage,ltq-hcd-ar10))
diff --git a/package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c b/package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c
index c30cf449148..04346b972f0 100644
--- a/package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c
+++ b/package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c
@@ -315,6 +315,8 @@ static int ifxusb_driver_probe(struct platform_device *_pdev)
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx100");
 #elif defined __IS_VR9__
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-xrx200");
+#elif defined __IS_AR10__
+        np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx300");
 #endif
 	if (!np) {
 		dev_err(&_pdev->dev, "failed to find hcd device node\n");
-- 
GitLab