From d0e1033a2682e660e7da3dd7c396ed33668cfceb Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 9 Feb 2007 16:24:34 +0000
Subject: [PATCH] more fixes for rstrip.sh and kernel modules - fixes #1301

SVN-Revision: 6280
---
 rules.mk          |  3 ++-
 scripts/rstrip.sh | 23 +++++++++++++++++++++--
 2 files changed, 23 insertions(+), 3 deletions(-)

diff --git a/rules.mk b/rules.mk
index b63fcf31c8f..a6188f4a6ba 100644
--- a/rules.mk
+++ b/rules.mk
@@ -87,8 +87,9 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
diff --git a/scripts/rstrip.sh b/scripts/rstrip.sh
index 252522bfaa1..6dd44f2ed27 100755
--- a/scripts/rstrip.sh
+++ b/scripts/rstrip.sh
@@ -6,6 +6,23 @@
 # See /LICENSE for more information.
 #
 
+find_modparams() {
+	FILE="$1"
+	$NM "$FILE" | awk '
+BEGIN {
+	FS=" "
+}
+($3 ~ /^__module_parm_/) && ($3 !~ /^__module_parm_desc/) {
+	gsub(/__module_parm_/, "", $3)
+	printf "-K " $3 " "
+}
+($2 ~ /r/) && ($3 ~ /__param_/) {
+	gsub(/__param_/, "", $3)
+	printf "-K " $3 " "
+}
+'
+}
+
 
 SELF=${0##*/}
 
@@ -28,9 +45,11 @@ find $TARGETS -type f -a -exec file {} \; | \
   IFS=":"
   while read F S; do
     echo "$SELF: $F:$S"
-	[ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && \
-		eval "$STRIP_KMOD $F" || \
+	[ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && {
+		eval "$STRIP_KMOD -w -K '__param*' -K '__mod*' $(find_modparams "$F")$F"
+	} || {
 		eval "$STRIP $F"
+	}
   done
   true
 )
-- 
GitLab