diff --git a/include/image-commands.mk b/include/image-commands.mk
index 9db150c9050954813f8b1c13a2702d955d27a37c..7ff4c217a345e10a2a399e56fa45bc4ff3644209 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -130,6 +130,10 @@ define Build/pad-to
 	mv $@.new $@
 endef
 
+define Build/pad-extra
+	dd if=/dev/zero bs=$(1) count=1 >> $@
+endef
+
 define Build/pad-rootfs
 	$(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
 		$(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index ab91d066c620446e3d18868e17786f2b8a029893..62e55dcf5d71a4a6fe5754315a942d0d388a203e 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -13,9 +13,8 @@ define Device/Default
   KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
   KERNEL := kernel-bin | strip-kernel | patch-cmdline
   IMAGES := sysupgrade.tar
-  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
   IMAGE/sysupgrade.tar := sysupgrade-tar
-  FILESYSTEMS := squashfs
 endef
 
 define Build/strip-kernel
@@ -29,14 +28,14 @@ define Device/generic
 endef
 TARGET_DEVICES += generic
 
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,15 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
 define Device/er
   CMDLINE := $(ER_CMDLINE) 
   DEVICE_TITLE := Ubiquiti EdgeRouter
 endef
 TARGET_DEVICES += er
 
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
 define Device/erlite
   CMDLINE := $(ERLITE_CMDLINE) 
   DEVICE_TITLE := Ubiquiti EdgeRouter Lite