diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index fc1b8fe0d22137a22ea541fb7e07bd14a5f2925f..d8db054312484cf1e11fa8502f46095a071009cc 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1705,7 +1705,6 @@ define Device/openmesh_common_64k
   DEVICE_VENDOR := OpenMesh
   DEVICE_PACKAGES := uboot-envtools
   IMAGE_SIZE := 7808k
-  BLOCKSIZE := 64k
   OPENMESH_CE_TYPE :=
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
 	pad-to $$(BLOCKSIZE)
@@ -1978,7 +1977,6 @@ define Device/plasmacloud_pa300-common
   DEVICE_VENDOR := Plasma Cloud
   DEVICE_PACKAGES := uboot-envtools
   IMAGE_SIZE := 7168k
-  BLOCKSIZE := 64k
   IMAGES += factory.bin
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
   IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA300
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 20cb2f60fab30d775aecf116c20ca9923c7436ce..52631789d9c5b34bd40743cf79eea784efa77aaa 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -102,7 +102,6 @@ TARGET_DEVICES += glinet_gl-ar300m-nand
 define Device/glinet_gl-ar300m-nor
   $(Device/glinet_gl-ar300m-common-nand)
   DEVICE_VARIANT := NOR
-  BLOCKSIZE := 64k
   SUPPORTED_DEVICES += glinet,gl-ar300m-nand gl-ar300m
 endef
 TARGET_DEVICES += glinet_gl-ar300m-nor
@@ -128,7 +127,6 @@ TARGET_DEVICES += glinet_gl-ar750s-nor-nand
 define Device/glinet_gl-ar750s-nor
   $(Device/glinet_gl-ar750s-common)
   DEVICE_VARIANT := NOR
-  BLOCKSIZE := 64k
   SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s glinet,gl-ar750s-nor-nand
 endef
 TARGET_DEVICES += glinet_gl-ar750s-nor