From e1e4cbde5ceb228e60fff1fc752cb90d9a7df2ab Mon Sep 17 00:00:00 2001
From: Paul Fertser <fercerpav@gmail.com>
Date: Fri, 21 Jan 2022 20:12:29 +0300
Subject: [PATCH] x86: geode: add kmod-crypto-ebc needed for hw acceleration

Module kmod-crypto-hw-geode provides accelerated cbc(aes) and ecb(aes)
but the software implementation is also needed when AES key size isn't
128 so that the operation can fall back. Add the kmod so that it would
all work as expected out of the box.

Tested-by: timur_davletshin
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
---
 target/linux/x86/image/geode.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/target/linux/x86/image/geode.mk b/target/linux/x86/image/geode.mk
index 6cea887926d..ce5e93a2c5b 100644
--- a/target/linux/x86/image/geode.mk
+++ b/target/linux/x86/image/geode.mk
@@ -1,7 +1,8 @@
 define Device/generic
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := x86/Geode
-  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio
+  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-ebc kmod-crypto-hw-geode \
+	kmod-ledtrig-gpio
   GRUB2_VARIANT := legacy
 endef
 TARGET_DEVICES += generic
-- 
GitLab