From e2193a69c83506ceaddefb2fd3f175059e1b5bcc Mon Sep 17 00:00:00 2001
From: Steven Barth <cyrus@openwrt.org>
Date: Fri, 1 Feb 2013 13:38:47 +0000
Subject: [PATCH] odhcp6c: allow IPv6-config via SLAAC-only if no prefix is
 requested

SVN-Revision: 35421
---
 package/network/ipv6/odhcp6c/Makefile        | 4 ++--
 package/network/ipv6/odhcp6c/files/dhcpv6.sh | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 7b616c9c91c..30ec89e43ad 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-02-01
+PKG_VERSION:=2013-02-01.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=7b3e29a4ff20f1b1e91fa65b5a0631462dbee06d
+PKG_SOURCE_VERSION:=6016539b9b73f3dc45b3df92554fca1b5d6431b7
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index 99867cd99dc..4bd3a67ed90 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -9,15 +9,15 @@ proto_dhcpv6_init_config() {
 	proto_config_add_string "reqprefix"
 	proto_config_add_string "clientid"
 	proto_config_add_string "reqopts"
-	proto_config_add_string "allow_slaaconly"
+	proto_config_add_string "noslaaconly"
 }
 
 proto_dhcpv6_setup() {
 	local config="$1"
 	local iface="$2"
 
-	local reqaddress reqprefix clientid reqopts allow_slaaconly
-	json_get_vars reqaddress reqprefix clientid reqopts allow_slaaconly
+	local reqaddress reqprefix clientid reqopts noslaaconly
+	json_get_vars reqaddress reqprefix clientid reqopts noslaaconly
 
 
 	# Configure
@@ -29,7 +29,7 @@ proto_dhcpv6_setup() {
 
 	[ -n "$clientid" ] && append opts "-c$clientid"
 
-	[ "$allow_slaaconly" = "1" ] && append opts "-S"
+	[ "$noslaaconly" = "1" ] && append opts "-S"
 
 	for opt in $reqopts; do
 		append opts "-r$opt"
-- 
GitLab