From ecb5c610be0358fc16132b324cd582afa156b599 Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Fri, 2 May 2014 22:56:33 +0000
Subject: [PATCH] kernel: fix dependency to xor-neon.ko

If this module gets build the xor module depends on it

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 40666
---
 package/kernel/linux/modules/lib.mk | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index af536270f60..cd919ba62e9 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -138,8 +138,15 @@ define KernelPackage/lib-xor
   TITLE:=XOR blocks algorithm support
   HIDDEN:=1
   KCONFIG:=CONFIG_XOR_BLOCKS
+ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+  FILES:= \
+    $(LINUX_DIR)/crypto/xor.ko \
+    $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+  AUTOLOAD:=$(call AutoProbe,xor-neon xor)
+else
   FILES:=$(LINUX_DIR)/crypto/xor.ko
   AUTOLOAD:=$(call AutoProbe,xor)
+endif
 endef
 
 define KernelPackage/lib-xor/description
-- 
GitLab