From f4fd2a1354a81e5222b6a263076538fbb7d4a090 Mon Sep 17 00:00:00 2001
From: Sungbo Eo <mans0n@gorani.run>
Date: Sat, 1 Jan 2022 22:00:56 +0900
Subject: [PATCH] mvebu: remove duplicate CONFIG_POWER_RESET entries

The option is already enabled in the target config since 9149ed4f05f8
("mvebu: cortexa9: Add support for Ctera C200-V2").

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
---
 target/linux/mvebu/cortexa53/config-5.10 | 1 -
 target/linux/mvebu/cortexa72/config-5.10 | 1 -
 target/linux/mvebu/modules.mk            | 5 +----
 3 files changed, 1 insertion(+), 6 deletions(-)

diff --git a/target/linux/mvebu/cortexa53/config-5.10 b/target/linux/mvebu/cortexa53/config-5.10
index 79f815b6d26..a47d66c6698 100644
--- a/target/linux/mvebu/cortexa53/config-5.10
+++ b/target/linux/mvebu/cortexa53/config-5.10
@@ -62,7 +62,6 @@ CONFIG_PHY_MVEBU_A3700_UTMI=y
 CONFIG_PINCTRL_ARMADA_37XX=y
 CONFIG_PINCTRL_ARMADA_AP806=y
 CONFIG_PINCTRL_ARMADA_CP110=y
-CONFIG_POWER_RESET=y
 CONFIG_POWER_SUPPLY=y
 CONFIG_QUEUED_RWLOCKS=y
 CONFIG_QUEUED_SPINLOCKS=y
diff --git a/target/linux/mvebu/cortexa72/config-5.10 b/target/linux/mvebu/cortexa72/config-5.10
index be78be5a34c..740f0fcfdfb 100644
--- a/target/linux/mvebu/cortexa72/config-5.10
+++ b/target/linux/mvebu/cortexa72/config-5.10
@@ -71,7 +71,6 @@ CONFIG_PHY_MVEBU_CP110_COMPHY=y
 CONFIG_PINCTRL_ARMADA_37XX=y
 CONFIG_PINCTRL_ARMADA_AP806=y
 CONFIG_PINCTRL_ARMADA_CP110=y
-CONFIG_POWER_RESET=y
 CONFIG_POWER_SUPPLY=y
 CONFIG_QUEUED_RWLOCKS=y
 CONFIG_QUEUED_SPINLOCKS=y
diff --git a/target/linux/mvebu/modules.mk b/target/linux/mvebu/modules.mk
index 8d4dc4d9681..2700e2b1593 100644
--- a/target/linux/mvebu/modules.mk
+++ b/target/linux/mvebu/modules.mk
@@ -2,10 +2,7 @@ define KernelPackage/linkstation-poweroff
   SUBMENU:=$(OTHER_MENU)
   DEPENDS:=@TARGET_mvebu
   TITLE:=Buffalo LinkStation power off driver
-  KCONFIG:= \
-	CONFIG_POWER_RESET=y \
-	CONFIG_POWER_RESET_LINKSTATION
-
+  KCONFIG:=CONFIG_POWER_RESET_LINKSTATION
   FILES:=$(LINUX_DIR)/drivers/power/reset/linkstation-poweroff.ko
   AUTOLOAD:=$(call AutoLoad,31,linkstation-poweroff,1)
 endef
-- 
GitLab