From f80c6e9e292877d4c94a27fd46f73390b30d781c Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 8 Nov 2006 14:28:49 +0000
Subject: [PATCH] use target nm instead of host nm for ar7 images (#936)

SVN-Revision: 5473
---
 target/image/ar7/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/target/image/ar7/Makefile b/target/image/ar7/Makefile
index d2af2d9a815..bcdef970cfb 100644
--- a/target/image/ar7/Makefile
+++ b/target/image/ar7/Makefile
@@ -57,7 +57,7 @@ endef
 define Image/Prepare
 	cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
 	$(TARGET_CROSS)ld -T $(PKG_BUILD_DIR)/zimage.script -r -b binary $(KDIR)/vmlinux.lzma -o $(KDIR)/zimage.o
-	$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=0x$${shell nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} -T $(PKG_BUILD_DIR)/ld.script \
+	$(TARGET_CROSS)ld -static -G 0 --defsym kernel_entry=0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} -T $(PKG_BUILD_DIR)/ld.script \
 		$(PKG_BUILD_DIR)/loader.o \
 		$(PKG_BUILD_DIR)/LzmaDecode.o \
 		$(KDIR)/zimage.o \
-- 
GitLab