diff --git a/Config.in b/Config.in
index 2efd1ce25d8f9bbf21fe3056d830b7c92dfab57f..65c7dc6c3afd9dbf3bef7d3ad6ed47f2233ae29b 100644
--- a/Config.in
+++ b/Config.in
@@ -103,10 +103,19 @@ comment "Image Options"
 
 source "target/linux/*/image/Config.in"
 
-	config TARGET_ROOTFS_FSPART
-		int "Filesystem part size (in MB)"
-		depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
-		default 16
+    config TARGET_ROOTFS_FSPART
+        int "Filesystem part size (in MB)"
+        depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+        default 16
+        help
+            Allows you to change the filesystem partition size
+
+    config TARGET_ROOTFS_MAXINODE
+        int "Maximum number of inodes in filesystem"
+        depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+        default 1500
+        help
+            Allows you to change the maximum number of inodes in the filesystem
 
 endmenu
 
diff --git a/include/image.mk b/include/image.mk
index 4f638f026094b2a4bec81bd716921fbc739a246f..ec0512f904ffeb1ff1f003c9ab4636f1947c03c5 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-		$(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+		$(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
 		$(call Image/Build,ext2)
   endef
 endif