From fe05a0887b0beaed9c1c295de2373222a8f85b44 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 8 Mar 2010 17:17:46 +0000
Subject: [PATCH] mkimage: fix spurious build errors caused by its braindead
 build system

SVN-Revision: 20065
---
 tools/mkimage/Makefile | 1 +
 1 file changed, 1 insertion(+)

diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index f8d7197e132..c2cbb53a2d5 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -19,6 +19,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
+	rm -f $(HOST_BUILD_DIR)/tools/.depend
 	touch $(HOST_BUILD_DIR)/include/config.{h,mk} $(HOST_BUILD_DIR)/include/autoconf.mk{.dep,}
 	$(MAKE) -C $(HOST_BUILD_DIR) SUBDIRS=tools BIN_FILES-y="mkimage" tools
 endef
-- 
GitLab