Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
0b98f1f6
Commit
0b98f1f6
authored
14 years ago
by
Gabor Juhos
Browse files
Options
Downloads
Patches
Plain Diff
ar71xx: rework WNDR3700 image generation
SVN-Revision: 24983
parent
b99f5f9c
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
target/linux/ar71xx/image/Makefile
+19
-16
19 additions, 16 deletions
target/linux/ar71xx/image/Makefile
with
19 additions
and
16 deletions
target/linux/ar71xx/image/Makefile
+
19
−
16
View file @
0b98f1f6
...
@@ -342,14 +342,14 @@ define Image/Build/CyberTAN
...
@@ -342,14 +342,14 @@ define Image/Build/CyberTAN
rm
$(KDIR)/image.tmp
rm
$(KDIR)/image.tmp
endef
endef
wndr3700_mtdlayout
=
mtdparts
=
spi0.0:320k
(
u-boot
)
ro,128k
(
u-boot-env
)
ro,1024k
(
kernel
)
,6656k
(
rootfs
)
,64k
(
art
)
ro,7680k@0x70000
(
firmware
)
define
Image/Build/Netgear
define
Image/Build/WNDR3700
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
)
$($(
4
)))
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
)
$(
wndr3700_mtdlayout
))
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage
)
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage
)
mkdir
-p
$(KDIR)/wndr3700/image
mkdir
-p
$(KDIR)/wndr3700/image
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(KDIR)/vmlinux-$(2).uImage
\
$(KDIR)/vmlinux-$(2).uImage
\
$(KDIR)/wndr3700/image/uImage
$(KDIR)/wndr3700/image/uImage
\
$(5)
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma
\
$(STAGING_DIR_HOST)/bin/mksquashfs-lzma
\
$(KDIR)/wndr3700
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp
\
$(KDIR)/wndr3700
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp
\
-nopad
-noappend
-root-owned
-be
-nopad
-noappend
-root-owned
-be
...
@@ -361,22 +361,32 @@ define Image/Build/WNDR3700
...
@@ -361,22 +361,32 @@ define Image/Build/WNDR3700
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
\
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp2
\
$(KDIR)/vmlinux-$(2).uImage.squashfs
$(KDIR)/vmlinux-$(2).uImage.squashfs
\
$(5)
-rm
-f
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp*
-rm
-f
$(KDIR)/vmlinux-$(2).uImage.squashfs.tmp*
(
\
(
\
dd
if
=
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage.squashfs
bs
=
1024k
conv
=
sync
;
\
dd
if
=
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage.squashfs
bs
=
1024k
conv
=
sync
;
\
dd
if
=
$(
KDIR
)
/root.
$(
1
)
bs
=
64k
;
\
dd
if
=
$(
KDIR
)
/root.
$(
1
)
bs
=
64k
;
\
)
>
$(
call imgname,
$(
1
)
,
$(
2
))
-sysupgrade
.bin
)
>
$(
call imgname,
$(
1
)
,
$(
2
))
-sysupgrade
.bin
$(STAGING_DIR_HOST)/bin/mkdniimg
\
$(STAGING_DIR_HOST)/bin/mkdniimg
\
-B
WNDR3700
-v
OpenWrt.$(REVISION)
\
-B
$(6)
-v
OpenWrt.$(REVISION)
\
-i
$(
call
imgname,
$(
1
)
,
$(
2
))
-sysupgrade.bin
\
-i
$(
call
imgname,
$(
1
)
,
$(
2
))
-sysupgrade.bin
\
-o
$(
call
imgname,
$(
1
)
,
$(
2
))
-factory.img
-o
$(
call
imgname,
$(
1
)
,
$(
2
))
-factory.img
$(STAGING_DIR_HOST)/bin/mkdniimg
\
$(STAGING_DIR_HOST)/bin/mkdniimg
\
-B
WNDR3700
-v
OpenWrt.$(REVISION)
-r
"NA"
\
-B
$(6)
-v
OpenWrt.$(REVISION)
-r
"NA"
\
-i
$(
call
imgname,
$(
1
)
,
$(
2
))
-sysupgrade.bin
\
-i
$(
call
imgname,
$(
1
)
,
$(
2
))
-sysupgrade.bin
\
-o
$(
call
imgname,
$(
1
)
,
$(
2
))
-factory-NA.img
-o
$(
call
imgname,
$(
1
)
,
$(
2
))
-factory-NA.img
endef
endef
define
Image/Build/Netgear/initramfs
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
)
$($(
4
)))
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage
)
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(KDIR)/vmlinux-$(2).uImage
\
$(
call
imgname,
$(
1
)
,
$(
2
))
-uImage.bin
\
$(5)
endef
ifdef
CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
ifdef
CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
define
Image/Build/ZyXEL
define
Image/Build/ZyXEL
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
))
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
))
...
@@ -402,14 +412,6 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
...
@@ -402,14 +412,6 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
endef
endef
endif
endif
define
Image/Build/WNDR3700/initramfs
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
)
$(
wndr3700_mtdlayout
))
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage
)
$(STAGING_DIR_HOST)/bin/wndr3700
\
$(KDIR)/vmlinux-$(2).uImage
\
$(
call
imgname,
$(
1
)
,
$(
2
))
-uImage.bin
endef
define
Image/Build/Zcomax
define
Image/Build/Zcomax
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
))
$(
call
PatchKernelLzma,
$(
2
)
,
$(
3
))
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage.bin
)
$(
call
MkImageLzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.bin.lzma,
$(
KDIR
)
/vmlinux-
$(
2
)
.uImage.bin
)
...
@@ -630,8 +632,9 @@ define Image/Build/Profile/TLWR1043NDV1
...
@@ -630,8 +632,9 @@ define Image/Build/Profile/TLWR1043NDV1
$(
call
Image/Build/Template/
$(
fs_squash
)
/
$(
1
)
,TPLINK,tl-wr1043nd-v1,board
=
TL-WR1043ND,TL-WR1043NDv1
)
$(
call
Image/Build/Template/
$(
fs_squash
)
/
$(
1
)
,TPLINK,tl-wr1043nd-v1,board
=
TL-WR1043ND,TL-WR1043NDv1
)
endef
endef
wndr3700_mtdlayout
=
mtdparts
=
spi0.0:320k
(
u-boot
)
ro,128k
(
u-boot-env
)
ro,1024k
(
kernel
)
,6656k
(
rootfs
)
,64k
(
art
)
ro,7680k@0x70000
(
firmware
)
define
Image/Build/Profile/WNDR3700
define
Image/Build/Profile/WNDR3700
$(
call
Image/Build/Template/
$(
fs_64k
)
/
$(
1
)
,WNDR3700,wndr3700
,board
=
WNDR3700
)
$(
call
Image/Build/Template/
$(
fs_64k
)
/
$(
1
)
,
Netgear,wndr3700,board
=
WNDR3700,wndr3700
_mtdlayout,3700,
WNDR3700
)
endef
endef
define
Image/Build/Profile/AP96
define
Image/Build/Profile/AP96
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment