Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
1b226e4d
Commit
1b226e4d
authored
17 years ago
by
Nicolas Thill
Browse files
Options
Downloads
Patches
Plain Diff
add a '@KERNEL' download facility, tweak script
SVN-Revision: 8495
parent
b35e6fe3
No related branches found
No related tags found
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
include/kernel.mk
+1
-4
1 addition, 4 deletions
include/kernel.mk
package/udev/Makefile
+1
-6
1 addition, 6 deletions
package/udev/Makefile
package/util-linux/Makefile
+1
-4
1 addition, 4 deletions
package/util-linux/Makefile
scripts/download.pl
+17
-9
17 additions, 9 deletions
scripts/download.pl
with
20 additions
and
23 deletions
include/kernel.mk
+
1
−
4
View file @
1b226e4d
...
...
@@ -42,10 +42,7 @@ else
LINUX_SOURCE
:=
linux-
$(
LINUX_VERSION
)
.tar.bz2
TESTING
:=
$(
if
$(
findstring
-rc
,
$(
LINUX_VERSION
))
,/testing,
)
LINUX_SITE
:=
http://www.us.kernel.org/pub/linux/kernel/v
$(
KERNEL
)$(
TESTING
)
\
http://www.us.kernel.org/pub/linux/kernel/v
$(
KERNEL
)$(
TESTING
)
\
http://www.kernel.org/pub/linux/kernel/v
$(
KERNEL
)$(
TESTING
)
\
http://www.de.kernel.org/pub/linux/kernel/v
$(
KERNEL
)$(
TESTING
)
LINUX_SITE
:=
@KERNEL/linux/kernel/v
$(
KERNEL
)$(
TESTING
)
\
PKG_BUILD_DIR
?=
$(
KERNEL_BUILD_DIR
)
/
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
endif
...
...
This diff is collapsed.
Click to expand it.
package/udev/Makefile
+
1
−
6
View file @
1b226e4d
...
...
@@ -13,12 +13,7 @@ PKG_VERSION:=106
PKG_RELEASE
:=
1
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.bz2
PKG_SOURCE_URL
:=
ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/
\
http://ftp.kernel.org/pub/linux/utils/kernel/hotplug/
\
ftp://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/
\
http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/
\
ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
\
http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
PKG_SOURCE_URL
:=
@KERNEL/linux/utils/kernel/hotplug/
PKG_MD5SUM
:=
320ccd2d0f4540d10e021bafa14f8985
include
$(INCLUDE_DIR)/package.mk
...
...
This diff is collapsed.
Click to expand it.
package/util-linux/Makefile
+
1
−
4
View file @
1b226e4d
...
...
@@ -13,10 +13,7 @@ PKG_VERSION:=2.12r
PKG_RELEASE
:=
2
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.gz
PKG_SOURCE_URL
:=
ftp://ftp.kernel.org/pub/linux/utils/
$(
PKG_NAME
)
/
\
http://ftp.kernel.org/pub/linux/utils/
$(
PKG_NAME
)
/
\
ftp://ftp.de.kernel.org/pub/linux/utils/
$(
PKG_NAME
)
/
\
http://ftp.de.kernel.org/pub/linux/utils/
$(
PKG_NAME
)
/
PKG_SOURCE_URL
:=
@KERNEL/linux/utils/
$(
PKG_NAME
)
/
PKG_MD5SUM
:=
c261230b27fc0fbcc287c76884caf2d3
include
$(INCLUDE_DIR)/package.mk
...
...
This diff is collapsed.
Click to expand it.
scripts/download.pl
+
17
−
9
View file @
1b226e4d
...
...
@@ -112,15 +112,23 @@ foreach my $mirror (@ARGV) {
push
@mirrors
,
"
http://downloads.sourceforge.net/$1
";
}
}
elsif
(
$mirror
=~
/^\@GNU\/(.+)$/
)
{
my
$gnupath
=
$
1
;
push
@mirrors
,
"
ftp://ftp.gnu.org/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.mirror.nl/pub/mirror/gnu/
$gnupath
";
push
@mirrors
,
"
http://mirror.switch.ch/ftp/mirror/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.uu.net/archive/systems/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.eu.uu.net/pub/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.leo.org/pub/comp/os/unix/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.digex.net/pub/gnu/
$gnupath
";
push
@mirrors
,
"
ftp://ftp.gnu.org/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.belnet.be/mirror/ftp.gnu.org/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.mirror.nl/pub/mirror/gnu/$1
";
push
@mirrors
,
"
http://mirror.switch.ch/ftp/mirror/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.uu.net/archive/systems/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.eu.uu.net/pub/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.leo.org/pub/comp/os/unix/gnu/$1
";
push
@mirrors
,
"
ftp://ftp.digex.net/pub/gnu/$1
";
}
elsif
(
$mirror
=~
/^\@KERNEL\/(.+)$/
)
{
push
@mirrors
,
"
ftp://ftp.us.kernel.org/pub/$1
";
push
@mirrors
,
"
http://ftp.us.kernel.org/pub/$1
";
push
@mirrors
,
"
ftp://ftp.kernel.org/pub/$1
";
push
@mirrors
,
"
http://ftp.kernel.org/pub/$1
";
push
@mirrors
,
"
ftp://ftp.de.kernel.org/pub/$1
";
push
@mirrors
,
"
http://ftp.de.kernel.org/pub/$1
";
push
@mirrors
,
"
ftp://ftp.fr.kernel.org/pub/$1
";
push
@mirrors
,
"
http://ftp.fr.kernel.org/pub/$1
";
}
else
{
push
@mirrors
,
$mirror
;
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment