Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
1d05e688
Commit
1d05e688
authored
16 years ago
by
Florian Fainelli
Browse files
Options
Downloads
Patches
Plain Diff
Allow mac80211 drivers to work in master mode
SVN-Revision: 12299
parent
2a888f2e
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
package/mac80211/Makefile
+2
-3
2 additions, 3 deletions
package/mac80211/Makefile
package/mac80211/patches/004-allow-ap-vlan-modes.patch
+25
-0
25 additions, 0 deletions
package/mac80211/patches/004-allow-ap-vlan-modes.patch
with
27 additions
and
3 deletions
package/mac80211/Makefile
+
2
−
3
View file @
1d05e688
...
@@ -12,10 +12,9 @@ include $(INCLUDE_DIR)/kernel.mk
...
@@ -12,10 +12,9 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME
:=
mac80211
PKG_NAME
:=
mac80211
PKG_RELEASE
:=
1
PKG_RELEASE
:=
1
PKG_VERSION
:=
$(
if
$(
CONFIG_TARGET_brcm47xx
)
,2008-05-26,2008-07-19
)
PKG_VERSION
:=
2008-08-06
PKG_SOURCE
:=
compat-wireless-
$(
PKG_VERSION
)
.tar.bz2
PKG_SOURCE
:=
compat-wireless-
$(
PKG_VERSION
)
.tar.bz2
PKG_SOURCE_URL
:=
$(
if
$(
CONFIG_TARGET_brcm47xx
)
,http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/05,http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/07
)
PKG_SOURCE_URL
:=
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/08/
#PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
PKG_BUILD_DIR
:=
$(
KERNEL_BUILD_DIR
)
/compat-wireless-
$(
PKG_VERSION
)
PKG_BUILD_DIR
:=
$(
KERNEL_BUILD_DIR
)
/compat-wireless-
$(
PKG_VERSION
)
include
$(INCLUDE_DIR)/package.mk
include
$(INCLUDE_DIR)/package.mk
...
...
This diff is collapsed.
Click to expand it.
package/mac80211/patches/004-allow-ap-vlan-modes.patch
0 → 100644
+
25
−
0
View file @
1d05e688
Subject: mac80211: allow AP and VLAN modes
This patch allows switching interfaces into AP/VLAN modes using
cfg80211 (nl80211). Don't allow doing it with wext because then
people will just attempt to do it manually (without hostapd) and
complain that it doesn't work.
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
---
net/mac80211/cfg.c | 4 ++++
1 file changed, 4 insertions(+)
--- everything.orig/net/mac80211/cfg.c 2008-08-06 21:38:13.000000000 +0200
+++ everything/net/mac80211/cfg.c 2008-08-06 21:38:24.000000000 +0200
@@ -33,6 +33,10 @@
nl80211_type_to_mac80211_type(enum nl802
case NL80211_IFTYPE_MESH_POINT:
return IEEE80211_IF_TYPE_MESH_POINT;
#endif
+ case NL80211_IFTYPE_AP:
+ return IEEE80211_IF_TYPE_AP;
+ case NL80211_IFTYPE_AP_VLAN:
+ return IEEE80211_IF_TYPE_VLAN;
case NL80211_IFTYPE_WDS:
return IEEE80211_IF_TYPE_WDS;
default:
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment