Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
1da945b7
Commit
1da945b7
authored
4 years ago
by
Felix Fietkau
Browse files
Options
Downloads
Patches
Plain Diff
tools/fakeroot: fix build regression on macOS
Signed-off-by:
Felix Fietkau
<
nbd@nbd.name
>
parent
8edb1797
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
tools/fakeroot/patches/301-glibc-2.33-compat-fixes.patch
+42
-0
42 additions, 0 deletions
tools/fakeroot/patches/301-glibc-2.33-compat-fixes.patch
with
42 additions
and
0 deletions
tools/fakeroot/patches/301-glibc-2.33-compat-fixes.patch
0 → 100644
+
42
−
0
View file @
1da945b7
--- a/libfakeroot.c
+++ b/libfakeroot.c
@@ -1368,7 +1368,8 @@
int renameat(int olddir_fd, const char *
#endif /* HAVE_FSTATAT */
-#if defined(__GLIBC__) && __GLIBC_PREREQ(2,33)
+#if defined(__GLIBC__)
+#if __GLIBC_PREREQ(2,33)
/* Glibc 2.33 exports symbols for these functions in the shared lib */
int lstat(const char *file_name, struct stat *statbuf) {
return WRAP_LSTAT LSTAT_ARG(_STAT_VER, file_name, statbuf);
@@ -1413,6 +1414,7 @@
int renameat(int olddir_fd, const char *
return WRAP_MKNODAT MKNODAT_ARG(_STAT_VER, dir_fd, pathname, mode, &dev);
}
#endif
+#endif /* __GLIBC__ */
#endif /* GLIBC_PREREQ */
--- a/configure.ac
+++ b/configure.ac
@@ -182,6 +182,9 @@
AC_MSG_CHECKING([for type of arg of __xm
#include <fcntl.h>
#include <unistd.h>
]], [[
+#ifndef __GLIBC__
+#error no extra *
+#endif
int __xmknod ( int ver,
const char *pathname ,
mode_t mode , dev_t *dev);
@@ -208,6 +211,9 @@
AC_MSG_CHECKING([for type of arg of __xm
#include <fcntl.h>
#include <unistd.h>
]], [[
+#ifndef __GLIBC__
+#error no extra *
+#endif
int __xmknodat ( int ver,
int dirfd,
const char *pathname ,
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment