Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
373e5f5e
Commit
373e5f5e
authored
16 years ago
by
Felix Fietkau
Browse files
Options
Downloads
Patches
Plain Diff
add new option for enabling debugging symbols
SVN-Revision: 12591
parent
818729cf
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
Config.in
+12
-4
12 additions, 4 deletions
Config.in
rules.mk
+2
-2
2 additions, 2 deletions
rules.mk
with
14 additions
and
6 deletions
Config.in
+
12
−
4
View file @
373e5f5e
...
@@ -106,6 +106,18 @@ menuconfig BUILDOPTS
...
@@ -106,6 +106,18 @@ menuconfig BUILDOPTS
bool
bool
prompt "Build Options" if DEVEL
prompt "Build Options" if DEVEL
config DEBUG
bool
prompt "Enable debugging" if BUILDOPTS
select NO_STRIP
default n
help
Disables stripping and adds -g3 to the CFLAGS
config NO_STRIP
bool "Do not strip generated binaries (enable for native compiling)" if DEVEL
default n
config CLEAN_IPKG
config CLEAN_IPKG
bool
bool
prompt "Clean all ipkg files before building the rootfs" if BUILDOPTS
prompt "Clean all ipkg files before building the rootfs" if BUILDOPTS
...
@@ -142,10 +154,6 @@ config EXTERNAL_KERNEL_TREE
...
@@ -142,10 +154,6 @@ config EXTERNAL_KERNEL_TREE
prompt "Use external kernel tree" if DEVEL
prompt "Use external kernel tree" if DEVEL
default ""
default ""
config BUILD_DEVELOPER_SYSTEM
bool "build a non-stripped system, so gcc can be run natively on target" if DEVEL
default n
source "toolchain/Config.in"
source "toolchain/Config.in"
menuconfig BUILDSYSTEM_SETTINGS
menuconfig BUILDSYSTEM_SETTINGS
bool "Buildsystem settings"
bool "Buildsystem settings"
...
...
This diff is collapsed.
Click to expand it.
rules.mk
+
2
−
2
View file @
373e5f5e
...
@@ -63,7 +63,7 @@ TARGET_DIR:=$(BUILD_DIR)/root-$(BOARD)
...
@@ -63,7 +63,7 @@ TARGET_DIR:=$(BUILD_DIR)/root-$(BOARD)
IPKG_STATE_DIR
:=
$(
TARGET_DIR
)
/usr/lib/ipkg
IPKG_STATE_DIR
:=
$(
TARGET_DIR
)
/usr/lib/ipkg
TARGET_PATH
:=
$(
TOOLCHAIN_DIR
)
/bin:
$(
STAGING_DIR_HOST
)
/bin:
$(
STAGING_DIR
)
/host/bin:
$(
PATH
)
TARGET_PATH
:=
$(
TOOLCHAIN_DIR
)
/bin:
$(
STAGING_DIR_HOST
)
/bin:
$(
STAGING_DIR
)
/host/bin:
$(
PATH
)
TARGET_CFLAGS
:=
$(
TARGET_OPTIMIZATION
)
TARGET_CFLAGS
:=
$(
TARGET_OPTIMIZATION
)
$(
if
$(
CONFIG_DEBUG
)
,-g3
)
TARGET_CPPFLAGS
:=
-I
$(
STAGING_DIR
)
/usr/include -I
$(
STAGING_DIR
)
/include
TARGET_CPPFLAGS
:=
-I
$(
STAGING_DIR
)
/usr/include -I
$(
STAGING_DIR
)
/include
TARGET_LDFLAGS
:=
-L
$(
TOOLCHAIN_DIR
)
/lib -L
$(
STAGING_DIR
)
/usr/lib -L
$(
STAGING_DIR
)
/lib -Wl,-rpath-link=
$(
STAGING_DIR
)
/usr/lib
TARGET_LDFLAGS
:=
-L
$(
TOOLCHAIN_DIR
)
/lib -L
$(
STAGING_DIR
)
/usr/lib -L
$(
STAGING_DIR
)
/lib -Wl,-rpath-link=
$(
STAGING_DIR
)
/usr/lib
...
@@ -129,7 +129,7 @@ TARGET_CONFIGURE_OPTS:= \
...
@@ -129,7 +129,7 @@ TARGET_CONFIGURE_OPTS:= \
SIZE=
$(
TARGET_CROSS
)
size
SIZE=
$(
TARGET_CROSS
)
size
# strip an entire directory
# strip an entire directory
ifneq
($(CONFIG_
BUILD_DEVELOPER_SYSTEM
),)
ifneq
($(CONFIG_
NO_STRIP
),)
RSTRIP
:=
:
RSTRIP
:=
:
else
else
RSTRIP
:=
\
RSTRIP
:=
\
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment