Skip to content
Snippets Groups Projects
Commit 4420ddaa authored by Kevin Darbyshire-Bryant's avatar Kevin Darbyshire-Bryant
Browse files

kernel: clean up patch fuzz


Recent kernel bumps & target patch refactors have left some patch fuzz
around.  Refreshed kernel patches using update_kernel script.

Signed-off-by: default avatarKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
parent 18a53d43
No related branches found
No related tags found
No related merge requests found
Showing
with 18 additions and 30 deletions
...@@ -754,7 +754,7 @@ ...@@ -754,7 +754,7 @@
ptr = ip6hoff + sizeof(struct ipv6hdr); ptr = ip6hoff + sizeof(struct ipv6hdr);
--- a/include/net/neighbour.h --- a/include/net/neighbour.h
+++ b/include/net/neighbour.h +++ b/include/net/neighbour.h
@@ -273,8 +273,10 @@ static inline bool neigh_key_eq128(const @@ -274,8 +274,10 @@ static inline bool neigh_key_eq128(const
const u32 *n32 = (const u32 *)n->primary_key; const u32 *n32 = (const u32 *)n->primary_key;
const u32 *p32 = pkey; const u32 *p32 = pkey;
......
...@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net> ...@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
--- a/mm/page_alloc.c --- a/mm/page_alloc.c
+++ b/mm/page_alloc.c +++ b/mm/page_alloc.c
@@ -8489,8 +8489,6 @@ int alloc_contig_range(unsigned long sta @@ -8511,8 +8511,6 @@ int alloc_contig_range(unsigned long sta
/* Make sure the range is really isolated. */ /* Make sure the range is really isolated. */
if (test_pages_isolated(outer_start, end, false)) { if (test_pages_isolated(outer_start, end, false)) {
......
...@@ -23,7 +23,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com> ...@@ -23,7 +23,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
--- a/drivers/spi/spi.c --- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c +++ b/drivers/spi/spi.c
@@ -3058,6 +3058,7 @@ static int __spi_validate_bits_per_word( @@ -3114,6 +3114,7 @@ static int __spi_validate_bits_per_word(
*/ */
int spi_setup(struct spi_device *spi) int spi_setup(struct spi_device *spi)
{ {
...@@ -31,7 +31,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com> ...@@ -31,7 +31,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
unsigned bad_bits, ugly_bits; unsigned bad_bits, ugly_bits;
int status; int status;
@@ -3075,6 +3076,14 @@ int spi_setup(struct spi_device *spi) @@ -3131,6 +3132,14 @@ int spi_setup(struct spi_device *spi)
(SPI_TX_DUAL | SPI_TX_QUAD | SPI_TX_OCTAL | (SPI_TX_DUAL | SPI_TX_QUAD | SPI_TX_OCTAL |
SPI_RX_DUAL | SPI_RX_QUAD | SPI_RX_OCTAL))) SPI_RX_DUAL | SPI_RX_QUAD | SPI_RX_OCTAL)))
return -EINVAL; return -EINVAL;
......
...@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com> ...@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
--- a/drivers/spi/spi.c --- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c +++ b/drivers/spi/spi.c
@@ -3070,8 +3070,8 @@ int spi_setup(struct spi_device *spi) @@ -3126,8 +3126,8 @@ int spi_setup(struct spi_device *spi)
if (ctlr->use_gpio_descriptors && ctlr->cs_gpiods && if (ctlr->use_gpio_descriptors && ctlr->cs_gpiods &&
ctlr->cs_gpiods[spi->chip_select] && !(spi->mode & SPI_CS_HIGH)) { ctlr->cs_gpiods[spi->chip_select] && !(spi->mode & SPI_CS_HIGH)) {
......
Index: linux-5.4.77/arch/mips/Kbuild.platforms --- a/arch/mips/Kbuild.platforms
=================================================================== +++ b/arch/mips/Kbuild.platforms
--- linux-5.4.77.orig/arch/mips/Kbuild.platforms
+++ linux-5.4.77/arch/mips/Kbuild.platforms
@@ -27,6 +27,7 @@ platforms += pistachio @@ -27,6 +27,7 @@ platforms += pistachio
platforms += pmcs-msp71xx platforms += pmcs-msp71xx
platforms += pnx833x platforms += pnx833x
...@@ -10,10 +8,8 @@ Index: linux-5.4.77/arch/mips/Kbuild.platforms ...@@ -10,10 +8,8 @@ Index: linux-5.4.77/arch/mips/Kbuild.platforms
platforms += rb532 platforms += rb532
platforms += sgi-ip22 platforms += sgi-ip22
platforms += sgi-ip27 platforms += sgi-ip27
Index: linux-5.4.77/arch/mips/Kconfig --- a/arch/mips/Kconfig
=================================================================== +++ b/arch/mips/Kconfig
--- linux-5.4.77.orig/arch/mips/Kconfig
+++ linux-5.4.77/arch/mips/Kconfig
@@ -630,6 +630,26 @@ config RALINK @@ -630,6 +630,26 @@ config RALINK
select ARCH_HAS_RESET_CONTROLLER select ARCH_HAS_RESET_CONTROLLER
select RESET_CONTROLLER select RESET_CONTROLLER
......
Index: linux-5.4.77/drivers/net/dsa/Kconfig --- a/drivers/net/dsa/Kconfig
=================================================================== +++ b/drivers/net/dsa/Kconfig
--- linux-5.4.77.orig/drivers/net/dsa/Kconfig
+++ linux-5.4.77/drivers/net/dsa/Kconfig
@@ -63,6 +63,8 @@ config NET_DSA_QCA8K @@ -63,6 +63,8 @@ config NET_DSA_QCA8K
This enables support for the Qualcomm Atheros QCA8K Ethernet This enables support for the Qualcomm Atheros QCA8K Ethernet
switch chips. switch chips.
...@@ -11,10 +9,8 @@ Index: linux-5.4.77/drivers/net/dsa/Kconfig ...@@ -11,10 +9,8 @@ Index: linux-5.4.77/drivers/net/dsa/Kconfig
config NET_DSA_REALTEK_SMI config NET_DSA_REALTEK_SMI
tristate "Realtek SMI Ethernet switch family support" tristate "Realtek SMI Ethernet switch family support"
depends on NET_DSA depends on NET_DSA
Index: linux-5.4.77/drivers/net/dsa/Makefile --- a/drivers/net/dsa/Makefile
=================================================================== +++ b/drivers/net/dsa/Makefile
--- linux-5.4.77.orig/drivers/net/dsa/Makefile
+++ linux-5.4.77/drivers/net/dsa/Makefile
@@ -21,3 +21,4 @@ obj-y += b53/ @@ -21,3 +21,4 @@ obj-y += b53/
obj-y += microchip/ obj-y += microchip/
obj-y += mv88e6xxx/ obj-y += mv88e6xxx/
......
Index: linux-5.4.77/net/dsa/tag_trailer.c --- a/net/dsa/tag_trailer.c
=================================================================== +++ b/net/dsa/tag_trailer.c
--- linux-5.4.77.orig/net/dsa/tag_trailer.c
+++ linux-5.4.77/net/dsa/tag_trailer.c
@@ -44,7 +44,12 @@ static struct sk_buff *trailer_xmit(stru @@ -44,7 +44,12 @@ static struct sk_buff *trailer_xmit(stru
trailer = skb_put(nskb, 4); trailer = skb_put(nskb, 4);
......
Index: linux-5.4.77/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
=================================================================== +++ b/drivers/net/phy/Makefile
--- linux-5.4.77.orig/drivers/net/phy/Makefile
+++ linux-5.4.77/drivers/net/phy/Makefile
@@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc.o @@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc.o
obj-$(CONFIG_NATIONAL_PHY) += national.o obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
......
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h
@@ -188,7 +188,7 @@ @@ -188,7 +188,7 @@ static inline const char *phy_modes(phy_
#define PHY_INIT_TIMEOUT 100000 #define PHY_INIT_TIMEOUT 100000
#define PHY_FORCE_TIMEOUT 10 #define PHY_FORCE_TIMEOUT 10
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment