Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
4f443c88
Commit
4f443c88
authored
3 years ago
by
Yousong Zhou
Browse files
Options
Downloads
Patches
Plain Diff
netfilter: separate packages for kmod-ipt-socket and kmod-ipt-tproxy
Signed-off-by:
Yousong Zhou
<
yszhou4tech@gmail.com
>
parent
9c335acc
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
include/netfilter.mk
+7
-6
7 additions, 6 deletions
include/netfilter.mk
package/kernel/linux/modules/netfilter.mk
+38
-1
38 additions, 1 deletion
package/kernel/linux/modules/netfilter.mk
with
45 additions
and
7 deletions
include/netfilter.mk
+
7
−
6
View file @
4f443c88
...
...
@@ -239,14 +239,15 @@ $(eval $(call nf_add,IPT_NFQUEUE,CONFIG_NETFILTER_XT_TARGET_NFQUEUE, $(P_XT)xt_N
$(
eval
$(
call nf_add,IPT_DEBUG,CONFIG_NETFILTER_XT_TARGET_TRACE,
$(
P_XT
)
xt_TRACE
))
# tproxy
# socket
$(
eval
$(
call nf_add,NF_SOCKET,CONFIG_NF_SOCKET_IPV4,
$(
P_V4
)
nf_socket_ipv4
))
$(
eval
$(
call nf_add,NF_SOCKET,CONFIG_NF_SOCKET_IPV6,
$(
P_V6
)
nf_socket_ipv6
))
$(
eval
$(
call nf_add,IPT_SOCKET,CONFIG_NETFILTER_XT_MATCH_SOCKET,
$(
P_XT
)
xt_socket
))
$(
eval
$(
call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_MATCH_SOCKET,
$(
P_XT
)
xt_socket
))
$(
eval
$(
call nf_add,
IPT
_TPROXY,CONFIG_NF_
SOCKET
_IPV4,
$(
P_V4
)
nf_
socket
_ipv4
))
$(
eval
$(
call nf_add,
IPT
_TPROXY,CONFIG_NF_
SOCKET
_IPV6,
$(
P_V6
)
nf_
socket
_ipv6
))
# tproxy
$(
eval
$(
call nf_add,
NF
_TPROXY,CONFIG_NF_
TPROXY
_IPV4,
$(
P_V4
)
nf_
tproxy
_ipv4
))
$(
eval
$(
call nf_add,
NF
_TPROXY,CONFIG_NF_
TPROXY
_IPV6,
$(
P_V6
)
nf_
tproxy
_ipv6
))
$(
eval
$(
call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_TARGET_TPROXY,
$(
P_XT
)
xt_TPROXY
))
$(
eval
$(
call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV4,
$(
P_V4
)
nf_tproxy_ipv4
))
$(
eval
$(
call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV6,
$(
P_V6
)
nf_tproxy_ipv6
))
# led
$(
eval
$(
call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED,
$(
P_XT
)
xt_LED
))
...
...
This diff is collapsed.
Click to expand it.
package/kernel/linux/modules/netfilter.mk
+
38
−
1
View file @
4f443c88
...
...
@@ -162,6 +162,28 @@ endef
$(
eval
$(
call KernelPackage,nf-flow
))
define
KernelPackage/nf-socket
SUBMENU
:=
$(
NF_MENU
)
TITLE
:=
Netfilter socket lookup support
KCONFIG
:=
$(
KCOFNIG_NF_SOCKET
)
FILES
:=
$(
foreach mod,
$(
NF_SOCKET-m
)
,
$(
LINUX_DIR
)
/net/
$(
mod
)
.ko
)
AUTOLOAD
:=
$(
call AutoProbe,
$(
notdir
$(
NF_SOCKET-m
)))
endef
$(
eval
$(
call KernelPackage,nf-socket
))
define
KernelPackage/nf-tproxy
SUBMENU
:=
$(
NF_MENU
)
TITLE
:=
Netfilter tproxy support
KCONFIG
:=
$(
KCOFNIG_NF_TPROXY
)
FILES
:=
$(
foreach mod,
$(
NF_TPROXY-m
)
,
$(
LINUX_DIR
)
/net/
$(
mod
)
.ko
)
AUTOLOAD
:=
$(
call AutoProbe,
$(
notdir
$(
NF_TPROXY-m
)))
endef
$(
eval
$(
call KernelPackage,nf-tproxy
))
define
AddDepends/ipt
SUBMENU
:=
$(
NF_MENU
)
DEPENDS
+=
+kmod-ipt-core
$(
1
)
...
...
@@ -645,9 +667,24 @@ endef
$(
eval
$(
call KernelPackage,ipt-led
))
define
KernelPackage/ipt-socket
TITLE
:=
Iptables socket matching support
DEPENDS
+=
+kmod-nf-socket +kmod-nf-conntrack
KCONFIG
:=
$(
KCONFIG_IPT_SOCKET
)
FILES
:=
$(
foreach mod,
$(
IPT_SOCKET-m
)
,
$(
LINUX_DIR
)
/net/
$(
mod
)
.ko
)
AUTOLOAD
:=
$(
call AutoProbe,
$(
notdir
$(
IPT_SOCKET-m
)))
$(
call
AddDepends/ipt
)
endef
define
KernelPackage/ipt-socket/description
Kernel
modules
for
socket
matching
endef
$(
eval
$(
call KernelPackage,ipt-socket
))
define
KernelPackage/ipt-tproxy
TITLE
:=
Transparent proxying support
DEPENDS
+=
+kmod-
ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
DEPENDS
+=
+kmod-
nf-tproxy +kmod-nf-conntrack
KCONFIG
:=
$(
KCONFIG_IPT_TPROXY
)
FILES
:=
$(
foreach mod,
$(
IPT_TPROXY-m
)
,
$(
LINUX_DIR
)
/net/
$(
mod
)
.ko
)
AUTOLOAD
:=
$(
call AutoProbe,
$(
notdir
$(
IPT_TPROXY-m
)))
...
...
This diff is collapsed.
Click to expand it.
Paul
@paul
mentioned in commit
289fbc51
·
3 years ago
mentioned in commit
289fbc51
mentioned in commit 289fbc5102a31e563d91cb8c99596bd63901406a
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment