Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openwrt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Freifunk Luebeck
openwrt
Commits
62ea398c
Commit
62ea398c
authored
12 years ago
by
Steven Barth
Browse files
Options
Downloads
Patches
Plain Diff
iptables: Add missing IPv6 builtin modules
SVN-Revision: 35898
parent
9779b0b8
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
include/netfilter.mk
+3
-1
3 additions, 1 deletion
include/netfilter.mk
package/network/utils/iptables/Makefile
+3
-3
3 additions, 3 deletions
package/network/utils/iptables/Makefile
with
6 additions
and
4 deletions
include/netfilter.mk
+
3
−
1
View file @
62ea398c
...
...
@@ -144,6 +144,8 @@ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_IPV6,CONFIG_IP6_NF_MANGLE, $(P_V6)ip6ta
$(
eval
$(
if
$(
NF_KMOD
)
,
$(
call nf_add,IPT_IPV6,CONFIG_IP6_NF_QUEUE,
$(
P_V6
)
ip6_queue
)
,
))
$(
eval
$(
if
$(
NF_KMOD
)
,
$(
call nf_add,IPT_IPV6,CONFIG_IP6_NF_RAW,
$(
P_V6
)
ip6table_raw
)
,
))
$(
eval
$(
if
$(
NF_KMOD
)
,,
$(
call nf_add,IPT_CORE,CONFIG_IP6_NF_IPTABLES, ip6t_icmp6
)))
$(
eval
$(
call nf_add,IPT_IPV6,CONFIG_IP6_NF_MATCH_AH,
$(
P_V6
)
ip6t_ah
))
$(
eval
$(
call nf_add,IPT_IPV6,CONFIG_IP6_NF_MATCH_EUI64,
$(
P_V6
)
ip6t_eui64
))
$(
eval
$(
call nf_add,IPT_IPV6,CONFIG_IP6_NF_MATCH_FRAG,
$(
P_V6
)
ip6t_frag
))
...
...
@@ -283,7 +285,7 @@ IPT_BUILTIN += $(IPT_FILTER-y)
IPT_BUILTIN
+=
$(
IPT_IPOPT-y
)
IPT_BUILTIN
+=
$(
IPT_IPRANGE-y
)
IPT_BUILTIN
+=
$(
IPT_IPSEC-y
)
IPT_BUILTIN
+=
$(
IPT_IPV6-y
)
IPT_BUILTIN
+=
$(
IPT_IPV6-y
)
$(
IPT_IPV6-m
)
IPT_BUILTIN
+=
$(
IPT_NAT-y
)
IPT_BUILTIN
+=
$(
IPT_NAT_EXTRA-y
)
IPT_BUILTIN
+=
$(
IPT_NATHELPER-y
)
...
...
This diff is collapsed.
Click to expand it.
package/network/utils/iptables/Makefile
+
3
−
3
View file @
62ea398c
...
...
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME
:=
iptables
PKG_VERSION
:=
1.4.18
PKG_RELEASE
:=
1
PKG_RELEASE
:=
2
PKG_SOURCE
:=
$(
PKG_NAME
)
-
$(
PKG_VERSION
)
.tar.bz2
PKG_SOURCE_URL
:=
http://www.netfilter.org/projects/iptables/files
\
...
...
@@ -357,7 +357,7 @@ MAKE_FLAGS := \
COPT_FLAGS
=
"
$(
TARGET_CFLAGS
)
"
\
KERNEL_DIR
=
"
$(
LINUX_DIR
)
/user_headers/"
PREFIX
=
/usr
\
KBUILD_OUTPUT
=
"
$(
LINUX_DIR
)
"
\
BUILTIN_MODULES
=
"
$(
patsubst ipt_%,%,
$(
patsubst xt_%,%,
$(
IPT_BUILTIN
)
$(
IPT_CONNTRACK-m
)
$(
IPT_NAT-m
)))
"
BUILTIN_MODULES
=
"
$(
patsubst
ip6t_%,%,
$(
patsubst
ipt_%,%,
$(
patsubst xt_%,%,
$(
IPT_BUILTIN
)
$(
IPT_CONNTRACK-m
)
$(
IPT_NAT-m
)))
)
"
define
Build/InstallDev
$(INSTALL_DIR)
$(1)/usr/include
...
...
@@ -415,7 +415,7 @@ endef
define
BuildPlugin
define
Package/$(1)/install
$(INSTALL_DIR)
$$(1)/usr/lib/iptables
for
m
in
$(
patsubst
xt_%,ipt_%,
$(
2
))
$(
patsubst
ipt_%,xt_%,
$(
2
))
;
do
\
for
m
in
$(
patsubst
xt_%,ipt_%,
$(
2
))
$(
patsubst
ipt_%,xt_%,
$(
2
))
$(
patsubst
xt_%,ip6t_%,
$(
2
))
$(
patsubst
ip6t_%,xt_%,
$(
2
))
;
do
\
if
[
-f
$(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so
];
then
\
$(CP)
$(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so
$$(1)/usr/lib/iptables/
;
\
fi;
\
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment